Problem with configuration of multi wan connection

Hi

I am currently working on setting up Openwrt on 8devices Habanero development board. I am trying to set it up to have 3 wan and 2 lan ports and have the 3 wan been load-balance with the help of the mwan3 package.
I have flash 8devices own Openwrt to the board, which runs Openwrt 19.07 and installed the luci package to get the GUI. and also installed the mwan3.
image download: https://wiki.8devices.com/habanero
In the default configuration there are 1 wan on eth1 and 4 lan ports on eth0 setup as a bridge.

To setup the multi wan ports I tried following this video:

The current setup based on the video:
Switch menu overview

I had to do some small changes, which is not done in the video.

  1. As the vlan1 is changed to tagged in the switch menu, the LAN bridge in the interface menu changes it interface to use eth0.1 and here I had to manage changes to to use eth0 otherwise I would lose my LAN connection to the board.
  2. For the newly created vlan eth0.2 and eth0.3 I assigned firewall-zone to be "wan".

The 2 vlan 0.2 and 0.3, sinces to work as wan port and i can connect to the interface through both ports.
but now the first wan on eth1 does not work. If I connect a device to the port, it doesn't even get a IP from the DHCP which it should.
As soon as I create one of the new vlan 0.2 or 0.3, the eth1 stops working.

So does anyone know what is going wrong and how to fix it?

thanks in advance :smiley:

Regards Andreas

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde4:7c06:2d3d::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option metric '10'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 4'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 3'
        option vid '3'

config interface 'WAN2'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option metric '20'

config interface 'WAN3'
        option ifname 'eth0.3'
        option proto 'dhcp'
        option metric '30'

i just experiment with switch yesterday.
i think you should change

config interface 'lan'
        option type 'bridge'
        ...
        option ifname 'eth0'

to

config interface 'lan'
        option type 'bridge'
        ...
        option ifname 'eth0.1'

since eth0 means the whole eth0.1,eth0.2,eth0.3 (switch_vlan count)

correct me if im wrong

1 Like