Problem with bridging wireless interface onto OVS


Im trying to bridge wireless interface (ap0) on which I run hostapd onto ovs bridge (br1) (I have patched version of hostapd:

I tried this through command sudo ovs-vsctl add-port br1 ap0 and hostapd config file with option bridge=br1, which should do the same thing.

In both cases I can see ap0 listed with command sudo ovs-ofctl show br1.

Output looks like this:

OFPT_FEATURES_REPLY (xid=0x2): dpid:00004aab3763a94a
n_tables:254, n_buffers:0
actions: output enqueue set_vlan_vid set_vlan_pcp strip_vlan mod_dl_src mod_dl_dst mod_nw_src mod_nw_dst mod_nw_tos mod_tp_src mod_tp_dst
 9(ap0): addr:02:c0:ca:98:1d:01
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
 LOCAL(br1): addr:4a:ab:37:63:a9:4a
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
OFPT_GET_CONFIG_REPLY (xid=0x4): frags=normal miss_send_len=0

But I dont see any frames/packets on interface br1 checking with tcpdump

When I do the same thing with Linux bridges using brctl, I can observe data (DHCP discover and some other) fom client on the Linux bridge.

note: I dont use any encryption.

Did anyone have problem with this? Maybe Im missing something. Could you please point me to relevant info.

Thanks for suggestions.