Problem with bridging eth0 eth1 bat0

Hello everyone,

I have a problem with bridging my ethernet ports. At my device Asus Lyra Map-ac2200 I have two ethernet ports. One port is connected to my Router (an AVM FritzBox) while the other port is connected to my Laptop. My Laptop does not receive any IP from the Router. At the same time bridging seems to work somehow because my mesh and dumbAP's work fine.

To be more precise:
I followed Carlos Gomez guide on how to bridge using BATMAN in conjunction with 802.11s ( https://cgomesu.com/blog/Mesh-networking-openwrt-batman/ ).

  • I have setup 3 nodes (A,B,C) using 802.11s and BATMAN.
  • Node A is connected to my router (R) via cable.
  • Node B and C connect to each other and to node A via wifi ( 802.11s & BATMAN )
  • The router (R) acts as dhcp server and gateway.
  • Firewall and dhcp is disabled on all three nodes.
  • All nodes have a static IP assigned.
  • Every node expands the network from (R) utilizing their second wifi card and a uniqe SSID.
  • I can connect to any node using their unique SSID. Devices that connect via wifi to any of these nodes (A,B,C) receive an IP from R and are able to browse the web.
  • Devices that connect via cable to any node (A,B,C) and any port (eth0/eth1) do not receive an IP from R. Even when I setup a static IP for those devices they cannot ping R.

I have already asked a similar question today, on how to properly bridge WAN as LAN ( Setup WAN as LAN interface [ Lyra (MAP-AC2200) ] ) . Regarding to that answer I expected it to work, but it does not. Perhaps it has to do with my specific setup and I do not want to confuse someone who wants to know on how to properly bridge WAN with LAN at an Asus Lyra Map-ac2200 and therefor reads the other thread. This is why I opened this one - just in case, someone wonders.

Here my config files that I modified. They look almost the same on all three nodes. Only the IP's are unique.

root@OpenWrt:/etc/config# cat network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

#config globals 'globals'
#	option ula_prefix 'fd2b:e13b:cf25::/48'

config device
	option name 'br-default'
	option type 'bridge'
	list ports 'eth1'
	list ports 'eth0'
	list ports 'bat0'

config interface 'default'
	option device 'br-default'
	option proto 'static'
	option ipaddr '192.168.178.232'
	option netmask '255.255.255.0'
	option gateway '192.168.178.1'
	option dns '192.168.178.1'
#	option ip6assign '60'

#config interface 'wan'
#	option device 'eth0'
#	option proto 'dhcp'

#config interface 'wan6'
#	option device 'eth0'
#	option proto 'dhcpv6'



config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms '1'
        option ap_isolation '0'
        option bonding '0'
        option bridge_loop_avoidance '1'
        option distributed_arp_table '1'
        option fragmentation '1'
        option gw_mode 'off'
        #option gw_sel_class '20'
        #option gw_bandwidth '10000/2000'
        option hop_penalty '30'
        option isolation_mark '0x00000000/0x00000000'
        option log_level '0'
        option multicast_mode '1'
        option multicast_fanout '16'
        option network_coding '0'
        option orig_interval '1000'


config interface 'mesh'
        option proto 'batadv_hardif'
        option master 'bat0'
        option mtu '1560'
root@OpenWrt:/etc/config# cat wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option country 'DE'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option network 'default'
	option mode 'ap'
	option ssid 'wrt232'
	option encryption 'psk2+aes'
	option key 'passwordwrt123'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/soc/a000000.wifi'
	option country 'DE'
	option disabled '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '100'
	option hwmode '11a'
	option path 'platform/soc/a800000.wifi'
	option country 'DE'
	option disabled '0'

config wifi-iface 'wmesh'
	option device 'radio2'
	option network 'mesh'
	option mode 'mesh'
	option mesh_id 'MeshCloud'
	option encryption 'sae'
	option key 'MeshPassword123'
	option mesh_fwding '0'
	option mesh_ttl '1'
	option mcast_rate '24000'
	option disabled '0'

It looks like the settings above are correct. Bridging seems to work as intended.

It looks like the problem I have is bound to my Laptop and its Ubuntu Studio installation:
When plugging the cable in the ethernet port of the Laptop and connect that with one of the nodes I do not receive an IP as long as I do not disable Auto-Negotiation in the network manager.

  • After disabling Auto-Negotiation and setting it manually to 100mbits full duplex or 10Gbits full duplex I do receive an IP.
  • When set to 10mbits or 1Gbit full and half duplex I do not receive an Ip.

Using the same Laptop but booting into Windows 10, Auto-Negotiation succeeds and I do receive an IP without any failure.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.