Problem with 2.4 GHz wifi

[PLEASE HELP URGENT]

I have successfully flashed my Linksys wrt3200ACM router with Openwrt 18.06.1. I have also configured it to boot from a USB for more storage. This openwrt is behind my ISP's modem/router. I have successfully configured the network and now every device connected to the OpenWRT router is able to access the internet. Everything works, even when I have my phone connected to the 2.4 GHz wireless radio1 on the openwork router. So here is the problem I am facing.

--> What I am trying to do: I have an IoT device connected to the 2.4 GHz wireless network on my openwrt router. I am going thru setting this device up on this network. I have another phone connected on this same network.

---> Problem I am facing: When I go through the setup process of the IoT device, the IoT device is being discovered just fine. However, the setup initialization fails. The error on the IoT device says that, the wireless ssid cannot be detected.

To confirm that this was a problem with my OpenWrt router. I connected the same IoT device and phone on the 2.4 GHz radio of my ISP's router. The setup process worked in seconds.

So I am not quit sure how to debug this issue. Below is my network configuration, firewall configuration and wireless configurations

        config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option country 'US'
	option legacy_rates '1'
	option htmode 'VHT20'
	option channel 'auto'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option country 'US'
	option legacy_rates '1'
	option htmode 'HT20'
	option channel 'auto'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key '------------'
	option ssid 'OpenWrt-2.4'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option country 'US'
	option legacy_rates '1'
	option hwmode '11g'
	option channel 'auto'
	option htmode 'HT20'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt_3'
	option encryption 'psk2'
	option key '---------'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option encryption 'psk2'
	option key '------------'
	option network 'lan'
	option ssid 'openwrt'
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd80:3974:666e::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'
	option dns '75.75.75.75 75.75.76.76'
	option gateway '192.168.1.1'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '2'
config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option log '1'
	option masq '1'
	option mtu_fix '1'
	option network 'lan'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option mtu_fix '1'
	option input 'ACCEPT'
	option forward 'ACCEPT'
	option masq '1'
	option log '1'
	option network 'wan wan6'
wlan0     ESSID: "openwrt"
          Access Point: 60:38:E0:CC:88:3A
          Mode: Master  Channel: 44 (5.220 GHz)
          Tx-Power: 23 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -100 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 11AB:2B40 11AB:0000 [Marvell 88W8964]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "OpenWrt-2.4"
          Access Point: 60:38:E0:CC:88:39
          Mode: Master  Channel: 6 (2.437 GHz)
          Tx-Power: 30 dBm  Link Quality: 65/70
          Signal: -45 dBm  Noise: -94 dBm
          Bit Rate: 144.4 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 11AB:2B40 11AB:0000 [Marvell 88W8964]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

wlan2     ESSID: "OpenWrt_3"
          Access Point: 60:38:E0:CC:88:3B
          Mode: Master  Channel: 1 (2.412 GHz)
          Tx-Power: 0 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -73 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgnac
          Hardware: 02DF:9135 0000:0000 [Marvell 88W8887]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy2
root@OpenWrt:~# iwinfo radio0 info
         radio0    ESSID: unknown
          Access Point: 60:38:E0:CC:88:3A
          Mode: Master  Channel: 44 (5.220 GHz)
          Tx-Power: 23 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 11AB:2B40 11AB:0000 [Marvell 88W8964]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0
root@OpenWrt:~# iwinfo radio1 info
         radio1    ESSID: unknown
          Access Point: 60:38:E0:CC:88:39
          Mode: Master  Channel: 6 (2.437 GHz)
          Tx-Power: 30 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 11AB:2B40 11AB:0000 [Marvell 88W8964]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1
root@OpenWrt:~# iwinfo radio2 info
          radio2    ESSID: unknown
          Access Point: 60:38:E0:CC:88:3B
          Mode: Master  Channel: 1 (2.412 GHz)
          Tx-Power: 0 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11bgnac
          Hardware: 02DF:9135 0000:0000 [Marvell 88W8887]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy2

openwrt-18.06 is EOS, it's no longer supported (and 18.06.1 hasn't been for a long time).

I don't think this is possible, the OEM u-boot is very unlikely to probe- and boot USB storage.

mwlwifi (the driver behind this wireless chipset) is known to be very problematic to interoperate with other wireless chipsets, the popular IoT specific esp8266/ esp32 in particular. These issues are longstanding and won't be fixed, as Marvell/ NXP abandoned this chipset and its proprietary firmware two years ago (not that they were a good FOSS citizen before). Issues like these are ubiquitous with this wireless hardware. There are usually two approaches to work around these interoperability issues, both are not good and basically not acceptable.

  • disabling WMM, but WMM is a mandatory feature of 802.11n and above, so you 'voluntarily' restrict your wireless speed to <54 MBit/s (and in practice more like ~20-25 MBit/s).
    --> IoT happy, wifi unusable for anything serious
  • configuring the third, SDIO connected and mwifiex based, radio for IoT uses, but this radio (aside from introducing 'funny' region code issues) was never meant to be used for transmitting, it's original purpose was to continuously scan the 5 GHz band for potential DFS events and to help the radar avoidance algorithms. As a consequence this radio is tuned to the 5 GHz band (although it technically supports 2.4 GHz as well), isn't connected to a real antenna, and is slow (1x1 and SDIO bus).
    --> normal wireless unaffected, but regdom intersection messed up, bad range and speed for the IoT network.

The only real solution would be switching away from this POS wireless chipset, by using a different wireless router with a sane/ supported wireless chipset/ firmware/ driver.

3 Likes

Hi Slh,

Thanks for this information. You pointed out a lot of useful information here. This was very informative to me:).

However, that is a bummer for me though since I need to get this done. I am wiling to pursue the real solution to get this working. What are some examples of other routers out there with the supported wireless chipset that will let me do something like this. Keep in mind that, these routers should support OpenWRT 19.07.

Thanks

This solved my issue finally. Thanks a lot @slh

This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.