Hi all, I am using 3 TL-WR1043ND v2 and 1 TL-WR1043ND v3 as manageable configurable VLAN-Switches. NAT and Firewall is done by OPNsense with amd thin client hw.
Cableing is as follows:
LAN1: Trunk in, LAN2: some PC w/o tags, LAN 3 some printer w/o tags, LAN4: Trunk out to next door in flat which has another 1043 and connects to LAN1 and so on. Quite nice, but error prone if a cable gets loose.
The Idea is to have an essid in every 1043 like
"network" to serve vlan 101
"guest" to seve vlan 100
"university" to serve vlan 200
"library" to serve vlan 201 (university vpn to library for ebooks)
etc.
every router at a different channel so wifi coverage is no question at all.
The problem is that VLAN is not routed to the configured access point, e.g.
phy0-ap0
I can use tcpdump -i phy0-ap0 and see dhcp requests but there is no answer and no dhcp traffic on the corrosponding vlan.
tcpdump -i eth0.101
I also tried to set up a bridge called br-101 which contains eth0.101. Does not change. In bridge config one can not include the ap into the bridge but one gets told to have a net 101 which contains eth0.101 or br-101 and to add the "interface" in the wireless setting. But this does not help.
Funny enough I could not see the bridge with brctl, but was able to manually create it:
brctl addbr br-101
brctl addif br-101 eth0.101
rctl addif br-101 phy0-ap0
brctl show
bridge name bridge id STP enabled interfaces
br-101 8000.e8de27fd0db8 no eth0.101
phy0-ap0
But this did not help. I enabled wireless and got no link there. In order to be able to use wifi, all the 1043 wifi stays disabled and the c2 access points create the wifi.
Very strange. DSA sucks, but fortunately the switch setup page was forgotten to "migrate" and one can see the switch and the vlans also link and so on.
Which is nice, as using the openwrt router as a vlan switch just works nicely.
I just want to use the hw vlan switch to add and strip vlan tags at gbit line speed and the cpu to connect an essid to a vlan.
Interestingly one can use eth0.101 or eth1.101 as both nics are connected to the vlan switch.
/etc/config/network:
config interface '101'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '10.0.101.11'
option gateway '10.0.101.1'
option delegate '0'
option device 'eth0.101'
option type 'bridge'
option broadcast '10.0.101.255'
...
config switch_vlan
option device 'switch0'
option vlan '3'
option vid '101'
option description 'LAN'
option ports '0t 1t 3 4t 6t'
config switch_vlan
option device 'switch0'
option vlan '4'
option vid '901'
option ports '0t 1t 4t'
config switch_vlan
option device 'switch0'
option vlan '5'
option vid '902'
option ports '0t 1t 4t'
...
config switch_vlan
option device 'switch0'
option vlan '16'
option vid '100'
option ports '0t 1t 4t 6t'
option description 'guest'
config device
option type 'bridge'
option name 'br-101'
list ports 'eth0.101'
option mtu '1500'
config bridge-vlan
option device 'br-101'
option vlan '101'
list ports 'eth0.101:t'
config device
option type 'bridge'
option name 'br-100'
list ports 'eth0.100'
option mtu '1500'
So what to do here?
Also I have: TP-Link Archer C2 v1 with a similar setup and it works with at leas one essid:
OpenWrt 23.05.4, also a similar custom build.
Here I added s fix into the S20network script at /etc/rc.common to disable the build-in vlan-switch of the SOC and to use the external VLAN-Switch on the board:
init_switch() {
#dirty hack for switch0 to pass RGMII and not to use it in luci with removed switch0 config
swconfig dev switch0 set enable_vlan 0
#/hack
setup_switch() { return 0; }
include /lib/network
setup_switch
}
(dont know if openwrt fixed the issue, but I fixed it for me here)
On TL-WR1043ND v2 and v3
firmware is custom build using the cool build tool of openwrt:
install: base-files busybox ca-bundle dnsmasq dropbear firewall4 fstools kmod-ath9k kmod-gpio-button-hotplug kmod-nft-offload kmod-usb-ledtrig-usbport kmod-usb2 libc libgcc libustream-mbedtls logd luci mtd netifd nftables odhcp6c odhcpd-ipv6only opkg ppp ppp-mod-pppoe procd procd-seccomp procd-ujail swconfig uboot-envtools uci uclient-fetch urandom-seed urngd wpad-basic-mbedtls bridge kmod-fs-reiserfs kmod-usb-net-rndis kmod-usb-serial-cp210x kmod-usb-serial-ftdi kmod-usb-storage serialconsole tc-full tcpdump kmod-usb-printer luci-app-p910nd luci-app-watchcat
The c2 also uses a similar custom build but this is not important here.
I love to use the swconfig, as this worked long time transparently and effectively.
What has been screwed up with the 1043, or am I just to stupid?