Problem using HT40 with lede and 1043ND v1 or 841N v11

Hi all, all my APs are running LEDE Reboot (SNAPSHOT, r5444-b83c325) and everyone uses only 20 mhz bands for wifi channels, even if I use HT40, HT40+ or HT40- in option htmode. Is it normal?

Also, using any other version of LEDE or openwrt, the problem is still the same: There is no way to increase channel width more than 20.

It is normal if there are a lot of other 2.4g aps around. Try noscan on your own responsibility.

Refer https://wiki.openwrt.org/doc/uci/wireless

yeah... there are no others ap...

Yes or no?

near me there are no overlapping AP

I'm testing in a country house where there are no others wifi. The noscan option as of now solved the problem, but I think there is a problem in this part

It sounds root caused.

WARNING ABOUT ENABLING NOSCAN FROM WIKI:

Turning this on will violate regulatory requirements!

If you are in FCC-US land for example, this will cause your device to run out of regulatory specifications (i.e. disable scanning for other SSIDs on the channel), meaning your device is not covered under its license and is running as an illegal transmitter.

The reason you likely receive 20 MHz bandwidth is because of congested 2.4 GHz channels.

See: Linksys WRT3200ACM only transmits with 20 MHz on the AC radio

That thread discusses the 20/40 issues in more detail.

definitely true. And do it on one's own responsibility.

1 Like

there are no other 2.4 ghz sources, so it's a strange thing. Also, if I use the original firware, it uses 40MHz channels instead of 20MHz

This MIGHT BE strange....are you looking while you are causing heavy bandwidth, such as when conducting a speed test???

I've seen that the LEDE firmware only increases bandwidth when needed. I have observed an Atheros device flip from 20 to 40 MHz seamlessly when doing things such as speed tests or streaming media. In addition, it will only change the width of the channel for the clients needing the additional bandwidth. I used the LuCI web GUI to observe this behavior on-the-fly.

This is likely true, because some stock firmwares...simply "omit" or "accidentally" set the noscan flag (or otherwise force 40 MHz).

1 Like

@pmera, have you checked 2.4G channel graph?

ahhhh ok, I was asking for this because wifi analyzer was saying all my APs with lede has 20mhz channels, instead the others (far) neighbour, that uses 40mhz channels.

the wireless networks found were these:

photo_2017-12-13_02-40-58

as you can see, there are no neighbour devices: router-main was irradiated from 841ND, Openwrt was irradiated by 1043ND, just flashed.

The network was not in heavy bandwidh use, so

would answer to the question.

Next time I'll be more meticolous, but as of now with lucy I was facing strange behaviour previous the noscan forcing: some devices were at 20 MHz, others at 40MHz.

from the APs or from client?

1 Like

Use some WiFi analyzer software. Otherwise how to be sure there is no one else is using the same channel?

look at my previous reply

photo_2017-12-13_02-40-58

Is there a reason you're not running 17.01.4?

Note that it doesn't necessarily have to be other access points that can cause spectral interference. A lot of devices broadcast in the 2.4 GHz band, digitally or analogue: cordless phones, analogue cameras, wireless doorbells, even your microwave.

1 Like