Problem unbricking TL-WR740N (3.0)


First of all, this is my first post (I'm sorry if im breaking a rule, or if i'm doing something wrong, in that case tell me and i'll fix it)
My TP-LINK 740n Is not working all leds are solid light except by one led

When i plug an ethernet cable, leds don't change, all leds still solid green.
I already tried 30/30/30 it doesn't work
and pressing reset doesn't change the pattern of leds because they start solid. It never blinks.
And sorry for my english, it's not my native language

The first question would be: What did you do before it "bricked"?

The boot process should say "32 MB", obviously for RAM. Yours says "4 MB". This might indicate that the RAM is broken, and if so, you are out of luck.

(Also: Obvious comment that a WR740N v3 was a low-end device more than 10 years ago, nowadays it is not good for anything really, OpenWrt support ended with 18.06.)

https://forum.openwrt.org/t/openwrt-19-07-x-ath79-tiny-luci/

Yeah I installed 18.06 it worked perfectly but i don't remember why i was trying to install a file named upgrade and i installed in an option that says "Backup" my bad... So... This time I can't fix it? :frowning: I know the router might not be one of the best but i really need it and if i could fix it i would like to.

I think the "4MB" is the flash mb
because the tp-link 740n have 32 MB RAM and 4 MB flash right?

I also have a mw330hp (Mercusys) but I don't see anythig about openwrt with it :frowning:

Other bootlogs state the memory size there. And it's telling that the boot process stops immediately after that line.

I'm pretty sure if the boot process stops there and doesn't even give you an option to enter anything, there's not much you can do anymore.

(Yes, you can desolder and reprogram the flash chips, but that seems a bit overkill for a device that people are not even bothering to give away for free anymore.)

But I'll happily stand corrected if someone else knows better.

2 Likes

Wait, so, reprogramming the chip is an option? XD with a CH341A programmer is enough?
If I can fix it with that, i would prefer to do that instead of leave it dead xD

For a single device, even if it were medium price range (which yours hasn't been a decade ago, when it was new, and certainly isn't today), the equipment necessary for the basics (serial console, spi-nor writer, clamps, soldering iron (better hot air desoldering station), flux, vacuum pump, solder wick, solder, etc.) vastly exceed the price of a new device (let alone a working used one) by a lot[0] - compared against an unclear success rate (namely the big question if the wifi calibration data is recoverable or if you have additional hardware damage (there must be a reason for this failure, that shouldn't happen on its own, during normal operations)).

--
[0] even if you buy directly in Asia and wait weeks/ months for the delivery, from local sources you can multiply the costs by five (lots of small stuff, not that costly individually, but with shipping you quickly exceed viability).

2 Likes