Problem to install a firmware OpenWrt to router netgear DGN 2200 v1

I have a Netgear DGN 2200 v1 router (first version) it is compatible with old versions of the openwrt firmware, but not with the latest ones because it has little ram memory. For this reason I downloaded the old compatible firmware "openwrt-15.05-brcm63xx-generic-96358VW-generic-squashfs-cfe.bin"

During the flash procedure, it hangs while loading the firmware file and from the command prompt of Putty it reads this string. CFE command error -21 other times instead command error -22
For the flash procedure I proceeded as follows:
enabled TFTP client on windows 10
I set the CH341A USB programmer to TTL (pin 2-3). I connected GND of the programmer to GND of the jtag pin GND of the Netgear DGN 2200 - TX of the programmer to RX of the router and Rx of the programmer to TX of the router.
I installed Putty and configured it to Serial - COM port 12 - baud 115200 - bit 8 - 1 - none . I set the IP of the network card of the PC like this:
IP address
gateways... nothing.
I installed TFTP and clicked on TFTP Client and set the path where the firmware file is.
I checked in device manager that the programmer is connected to COM port 12.
After all the connections and settings I opened Putty and accessed the router then immediately while booting the router on the putty command prompt, I pressed a pc key to block the boot.
Putty's command prompt stopped booting and said CFE with the cursor blinking.
Up to here everything has gone well as well as the guides I have seen indicated. Then next to CFE and the flashing cursor I wrote:
"f" and hit enter.
(for easy of writing on the prompt I renamed the firmware: from "openwrt-15.05-brcm63xx-generic-96358VW-generic-squashfs-cfe.bin to "stable.bin"
the loading phase started but then the block with the following writing resulted:
" Loading failed : CFE error -21 - command status = -21"
I tried to put the IP to the network card as some guides say
(even if the router doesn't have IP but and it can't even be changed from its webpage) for the sake of scruple, however, I tried with this IP and it stops immediately this time indicating that it can't find the firmware file and with the writing
" TFTP error File no found - Loading failed: CFE error -22 : command status -22"
I think I set the TFTP software wrong, but I don't know how to set it. How to solve the problem? Thank you

Buy something newer.

Generally speaking, this is a really outdated device with little to no potential of being a sustainable router. You are better off with the stock firmware if you intend to use it like an AP. At least it will be optimized for speed. The OpenWrt version you want to flash is even from before the LEDE time, I think. So just

and watch out for something like 64MB of flash if you intend to use it as a sustainable router.

32MB devices are not bad, but from what I see, they are going to drop support for them rather soon.
Anyway, there is always a third option where you run your router on a mini PC + managed switch + AP. And it may be the best option of all because it gives you a lot of flexibility.

hi, on the Netgear DGN 2200v1 router I managed to flash the openwrt-15.05-brcm63xx-generic-96358VW-generic-squashfs-cfe firmware using a usb ttl serial reader the putty software and the tftpd server. Later I noticed that this version of open wrt has the download packages in the list in limited number for example I didn't find the i18n-base it (Italian language) luci package either I didn't find the rtl8192 rt2800 and rtl8188 packages that are used with this router the wifi dongles of the ALFA AWUS036 series. Also you can't use the wifi. Then I searched on the official portal for the latest firmware compatible with this Netgear DGN 2200v1 and I installed the latest updated open wrt firmware version openwrt-19.07.10-brcm63xx-smp-96358VW-generic-squashfs-cfe .
With this version I noticed that I can't download a list of compatible packages (from A to Z); but luckily through OPENWRT portal I found the mips_mips32 package for this firmware version 19.07.10-brcm63xx-smp-96358VW-generic-squashfs-cfe. Some packages are not installed while others are, including at the moment I have installed: luci i18n-base it rtl8192se rtl8192cu
rtl8192de rtl8192su rtl8188eu rt2800usb.

I would like to know which packages I have to install to enable the wifi of the router and the usb packages to also enable the usb port. Thank you