Problem setting up mesh network

I tried to set up a mesh network with my EA6350v3, but can't find the mesh id (or SSID) in my smartphone. I tried to scan for WIFI, and the scanner found that WIFI signal is present, but only with the mesh id hidden.

Here's some info for the software:
openwrt version: 19.07.0
wifi package: wpad-mesh-openssl

  • Is your mesh running Ad-hoc or AP mode?
  • Does your phone allow connections to Ad-hoc
  • I'm curious (as I want to set up a mesh for a phone), what mesh app do you have installed on the phone?

They are set using mesh mode (802.11s) as stated in This is supposed to work easily, but just turned out not working for me.

1 Like

Anyway, the only thing I want to achieve in the mesh is to keep the connection (or internet sessions) alive when I move from node to node. There is backhaul between the mesh points.

A mesh is for inter-router linking. If you have wired backhaul you don't need a mesh. There is confusion on this point since many commercial mesh products also implement some sort of enhanced roaming. That isn't part of the mesh protocol, that is something that the AP interfaces in those products do.


Thanks a lot. I was completely mistaken.

Today I just checked the "mesh" in my workplace. Turns out to be a lot of APs with the same SSID. So I followed suit. Readers can find for help.

So here's the work in OpenWRT:

For the main router

  1. Set up OpenWRT for LAN and wireless in the usual way.
  2. Create a VLAN on the switch. Add that adapter (eth0.1111 in the picture) to the wlan interface (bridge eth0.1111 with wlan(s)), so they share the same DHCP and firewall zone.

For the other router

  1. Set up wireless network with the same SSID and key, but set it to "unmanaged" instead of "static address".
  2. Bridge wlan* and eth1.1111 (need to manually type that, 1111 = VLAN port) into the same interface.
  3. (optional) If you want LAN connectivity for the desktop computers across the routers, bridge eth0 and wan* together, and set the new bridged interface to DHCP.
    Note that this has a side effect allowing accessing LUCI/SSH from the WAN port. If you don't like this add firewall rules to block the communcations.

(BTW, it is quite tricky to set up the VLAN in EA6350v3. The trick is to leave the 2nd row of the VLAN config empty and untouched. P.S. some said that we cannot use LUCI, which turns out to be not needed. :slight_smile: )

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.