Problem maintaining connectivity after upgrade

I have what I think is a fairly standard setup. I just upgraded from OpenWrt 19.7 to OpenWrt 21.02.3.

After the upgrade, the connection to the website chess.com is very patchy when connected via wifi. This is a chess website, and it very often disconnects during the game (approximately it disconnects 1 time per minute, takes about 30 seconds to reconnect, sometimes it does not reconnect).

I have not other apparent problems. The connection can always be established, but just does not last.

I know it comes from the router, because if I switch to hotspot, connecting via my cellphone connection, it works flawlessly.

I tried to restart a few services, like network or dnsmasq, but it did not solve the problem.

What steps can I take to try and diagnose this problem? Are there logs I can look at? Any random idea as to what the problems could be?

Thanks!

Maybe the channel selection is at fault here.

This doesn't necessarily implicate the router -- it could be your ISP. When you turn off wifi on your phone, you switch to your mobile carrier, and therefore you are (probably) using a different ISP.

Have you tried a wired connection to your router?

Yes, in the main LuCI web interface > Status > System Log (or you can view this by issuing logread in the command line interface).

You also haven't given us enough information to be able to suggest possible culprits and resolutions.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

Thanks for your help. I thought I had solved the problem, but it reappeared.

I tried with openWrt 21.02.3, 21.02.2 and also the latest release candidate. The problem always ends up manifesting, though after a little while.

Here's the config:

/etc/config/network

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix REDACTED

config interface 'net'
	option type 'bridge'
	option proto 'static'
	option ipaddr REDACTED
	option netmask '255.255.255.0'

config interface 'wan'
	option proto 'dhcp'
	option peerdns '0'
	option device 'eth0.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config device
	option name 'br-net'
	option type 'bridge'
	list ports 'eth1.1'


/etc/config/wireless

config wifi-device 'radio1'
	option type 'mac80211'
	option band '2g'
	option path REDACTED
	option htmode 'HT20'
	option channel 'auto'

config wifi-iface 'radio1_net'
	option device 'radio1'
	option network 'net'
	option mode 'ap'
	option key REDACTED
	option ssid 'net'
	option encryption 'sae'
	option wpa_disable_eapol_key_retries '1'
	option ieee80211w '2'
	option isolate '1'
	option dtim_period '3'

/etc/config/dhcp

config dnsmasq 'dnsmasq_net'
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option domain 'net'
	option local '/net/'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp_net.leases'
	option noresolv '1'
	option localservice '1'
	list interface 'net'
	list notinterface 'loopback'
	option confdir '/tmp/dnsmasq.d'
	list server '8.8.8.8'	

/etc/config/firewall

config defaults
	option input 'REJECT'
	option output 'REJECT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'net'
	list network 'net'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'wan'
	list network 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'net'
	option dest 'wan'


config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule 'net_dhcp'
	option name 'Allow-DHCP-Net'
	option src 'kids'
	option dest_port '67'
	option family 'ipv4'
	option proto 'udp'
	option target 'ACCEPT'

config rule 'net_dns'
	option name 'Allow-DNS-Net'
	option src 'net'
	option dest_port '53'
	option proto 'tcp udp'
	option target 'ACCEPT'

config redirect 'net_intdns'
	option name 'Intercept-DNS-Net'
	option src 'net'
	option src_dport '53'
	option proto 'tcp udp'
	option target 'DNAT'

config rule 'dot_deny'
	option name 'Deny-DoT'
	option src '*'
	option dest 'wan'
	option dest_port '853'
	option proto 'tcp udp'
	option target 'REJECT'

config rule 'doh_deny'
	option name 'Deny-DoH'
	option src '*'
	option dest 'wan'
	option dest_port '443 80'
	option proto 'tcp udp'
	option family 'ipv4'
	option ipset 'doh dest'
	option target 'REJECT'

config include
	option path '/etc/firewall.user'

config ipset 'doh'
	option name 'doh'
	option family 'ipv4'
	option storage 'hash'
	option match 'ip'
	list entry '101.198.191.4'
	list entry '101.6.6.6'
	list entry '101.71.72.192'
	list entry '103.2.57.5'
	list entry '103.2.57.6'

Does anything look off here ?