Problem IPv6 on LAN

Good morning,

I am having a problem getting the LAN to use the IPv6 protocol. The router works perfectly but not the LAN.

Could you help me

Thanks in advance

Configuration Router

# ---------------------------------------------------------------------------------------------------
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option type 'bridge'
	option name 'Switch'
	list ports 'extsw'
	option ipv6 '1'

config interface 'LAN'
	option proto 'static'
	option device 'Switch'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	list ip6class 'WAN6'

config interface 'WAN'
	option proto 'static'
	option ipaddr '192.168.155.64'
	option netmask '255.255.255.0'
	option gateway '192.168.155.154'
	option broadcast '192.168.155.255'
	list dns '192.168.155.154'
	list dns '8.8.8.8'
	option delegate '0'

config interface 'WAN6'
	option proto 'static'
	list ip6addr '2a04:cec0:1079:23b5:1a31:bfff:fe5b:35a8/64'
	option ip6gw 'fe80::5489:bdff:fe08:d9a5'
	option ip6prefix '2a04:cec0:1079:23b5::/64'
	list dns '2001:860:d002:1201::129:201'
	list dns '2001:860:d002:1201::129:202'

# ---------------------------------------------------------------------------------------------------
root@OpenWrt:~# ifconfig 
Marc      Link encap:Ethernet  HWaddr 18:31:BF:5B:35:A8  
          inet addr:192.168.155.64  Bcast:192.168.155.255  Mask:255.255.255.0
          inet6 addr: fe80::1a31:bfff:fe5b:35a8/64 Scope:Link
          inet6 addr: 2a04:cec0:1079:23b5:1a31:bfff:fe5b:35a8/64 Scope:Global

Switch    Link encap:Ethernet  HWaddr 18:31:BF:5B:35:A8  
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::1a31:bfff:fe5b:35a8/64 Scope:Link
          inet6 addr: 2a04:cec0:1079:23b5::1/64 Scope:Global

eth1      Link encap:Ethernet  HWaddr 18:31:BF:5B:35:A8  
          inet6 addr: fe80::1a31:bfff:fe5b:35a8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

# ---------------------------------------------------------------------------------------------------
root@OpenWrt:~# ip -6 route show

2a04:cec0:1079:23b5::/64 dev Marc  metric 256 
2a04:cec0:1079:23b5::/64 dev Switch  metric 1024 

unreachable 2a04:cec0:1079:23b5::/64 dev lo  metric 2147483647 

fe80::/64 dev eth1  metric 256 
fe80::/64 dev Switch  metric 256 
fe80::/64 dev Marc  metric 256 
default via fe80::5489:bdff:fe08:d9a5 dev Marc  metric 1024 
anycast 2a04:cec0:1079:23b5:: dev Marc  metric 0 
anycast 2a04:cec0:1079:23b5:: dev Switch  metric 0 
anycast fe80:: dev eth1  metric 0 
anycast fe80:: dev Switch  metric 0 
anycast fe80:: dev Marc  metric 0 
multicast ff00::/8 dev eth1  metric 256 
multicast ff00::/8 dev Switch  metric 256 
multicast ff00::/8 dev Marc  metric 256

# ---------------------------------------------------------------------------------------------------
root@OpenWrt:~# ping -6 google.fr
PING google.fr (2a00:1450:4007:80e::2003): 56 data bytes
64 bytes from 2a00:1450:4007:80e::2003: seq=0 ttl=114 time=53.836 ms
64 bytes from 2a00:1450:4007:80e::2003: seq=1 ttl=114 time=68.262 ms
64 bytes from 2a00:1450:4007:80e::2003: seq=2 ttl=114 time=44.121 ms


My Computer

root@Drthrax:~# ifconfig 
enp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.18  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::ab8e:f71f:a58e:2881  prefixlen 64  scopeid 0x20<link>
        inet6 2a04:cec0:1079:23b5:1c53:80dc:6967:186e  prefixlen 64  scopeid 0x0<global>
        ether 04:d9:f5:82:2c:96  txqueuelen 1000  (Ethernet)
        RX packets 209035  bytes 184823467 (176.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 146463  bytes 24140443 (23.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xfc700000-fc71ffff  

# --------------------------------------------------------------------------------------------
root@Drthrax:~# ping -6 2a04:cec0:1079:23b5::1
PING 2a04:cec0:1079:23b5::1(2a04:cec0:1079:23b5::1) 56 data bytes
64 bytes from 2a04:cec0:1079:23b5::1: icmp_seq=1 ttl=64 time=0.210 ms
64 bytes from 2a04:cec0:1079:23b5::1: icmp_seq=2 ttl=64 time=0.208 ms
64 bytes from 2a04:cec0:1079:23b5::1: icmp_seq=3 ttl=64 time=0.190 ms

# --------------------------------------------------------------------------------------------
root@Drthrax:~# ip -6 r show
2a04:cec0:1079:23b5::/64 dev enp5s0 proto ra metric 100 pref medium
fe80::/64 dev enp5s0 proto kernel metric 1024 pref medium

# --------------------------------------------------------------------------------------------
root@Drthrax:~# ping -6 google.fr
PING google.fr(par10s22-in-x03.1e100.net (2a00:1450:4007:80e::2003)) 56 data bytes

# --------------------------------------------------------------------------------------------
root@Drthrax:~# ping -6 2a00:1450:4007:80e::2003
PING 2a00:1450:4007:80e::2003(2a00:1450:4007:80e::2003) 56 data bytes

# --------------------------------------------------------------------------------------------

The problem here is that the WAN IP and the LAN prefix are both in the exact same /64. This prevents routing from working. You only have a single /64 routed to your line (and apparently no separate /128 for the WAN interface itself), so PD is not going to work. In this case the ISP should not have advertised a PD to you, but ISPs are not always properly set up.

When there is only a single /64 present from the ISP, RA / NDP relay mode should be used.

On the LAN ?

Yes both LAN and WAN are set to relay, with the "master" bit set on WAN.

In this configuration (which is typical for 4G/5G LTE connections) the LAN will not actually hold a GUA IPv6. However when a host connects to the LAN, it will be advertised and select a GUA from the /64 that is on WAN. Then a /128 route for each host will be inserted into the v6 routing table.

WAN:

LAN:

It's good ?

On both lan and wan6, set RA and NDP proxy to "relay", but check the "master" box only on wan. You can also set up DHCPv6 as relay, but DHCPv6 is seldom necessary in a home network.

Also make sure ip6assign on lan is left blank. This prevents the PD system from interfering. PD cannot be used here because your ISP does not implement it correctly.

Hi,

it's not work, can you help me ?

WAN

Designated Master: X
RA-Service: Relay Mode
NDP-Proxy: Relay Mode

LAN

Troubleshoot a little deeper than "it does not work".

  • Does wan6 still have a /64 IP?
  • Does lan no longer have a GUA IP (you do want it not to have one.)
  • Check the network status on a LAN device, does it have a GUA within your /64?
  • Also on the LAN device, the DNS and the default v6 route should be the LLA (fe80::xxxx) of the router's LAN.
  • Check that DNS works on a LAN device and that it returns v6 addresses for v6-capable sites.
  • Does the v6 routing table have host (/128) routes to each LAN device via the LAN interface?

Hi,

Impossible ping router > PC (ipv6)

I'm sorry but I'm French and I don't fully understand the terms you use, remember to put the term found in the GUI please

My Computer:

root@Drthrax:~# ifconfig 
enp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.18  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::9ae7:88a9:af49:e888  prefixlen 64  scopeid 0x20<link>
        inet6 2a04:cec0:1079:23b5:26b2:f2c9:40a9:d85c  prefixlen 64  scopeid 0x0<global>
        ether 04:d9:f5:82:2c:96  txqueuelen 1000  (Ethernet)
        RX packets 533998  bytes 527504533 (503.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 355273  bytes 54010687 (51.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xfc700000-fc71ffff  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 12550  bytes 1351325 (1.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 12550  bytes 1351325 (1.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


root@Drthrax:~# ip -6 route
2a04:cec0:1079:23b5::/64 dev enp5s0 proto ra metric 100 pref medium
fe80::/64 dev enp5s0 proto kernel metric 1024 pref medium
default via fe80::1a31:bfff:fe5b:35a8 dev enp5s0 proto ra metric 100 pref high
root@Drthrax:~# ip -6 route show
2a04:cec0:1079:23b5::/64 dev enp5s0 proto ra metric 100 pref medium
fe80::/64 dev enp5s0 proto kernel metric 1024 pref medium
default via fe80::1a31:bfff:fe5b:35a8 dev enp5s0 proto ra metric 100 pref high

Router:

PING fe80::9ae7:88a9:af49:e888 (fe80::9ae7:88a9:af49:e888): 56 data bytes

--- fe80::9ae7:88a9:af49:e888 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss


Generic

WAN6


LAN