Problem installing openwrt on tp-link archer mr200 v1

Hi! Im trying to install openwrt on a tp-link archer mr200 v1, but I get an error message:

"error code:4506
the uploaded file does not match the device's current hardware version".

I am trying to install the supported firmware for this model.

Anyone had the same issue or knows about a work around?


What image did you download? (Exact filename and/or link to file)

What firmware is on the device now?

How did you attempt to install the file you downloaded?

1 Like

Not how it's supposed to be done

1 Like

Current firmware: 0.9.1 1.2 v004a.0 Build 180502 Rel.53881n

Tried to install with the device software(normal firmware upgrade)

I havn't tried with tftp yet.

Update: I just found documentation stating that the tftp installation process is the only way.
Never done that before so we'll see if I manage without bricking it.

Any good advise before I give it a go? :sweat_smile:

not your device, but the TFTP part is still relevant..

1 Like

Thank you so much! :blush:

How long is the installing process? It's been on now for about 30 min and it looks like its not finished yet, or its stuck in a boot loop. :confounded:

usually < 10 mins.

you could try an older release, then upgrade your way forward when already on openwrt.

the router won't go in recovery mode from now on which means it wont connect to the tftp software. I have not manage to find another way of unbrick it. Any suggestion?

serial connection is the next step, if you want to investigate the reason why it boot loops.

I figured!

found other topics with the same issue and the solution is not that straight forward.
Thank you for the advice anyways. I have to get a hold of a ch341 before I can try anything else :sleeping:


keep us updated.

1 Like