Problem installing firmware on TP-Link Archer C7 V1.1, OpenWRT working

#1

Hi, currently I fail to install any of the firmware images provided for Archer C7 V1 on my V1.1 router. This is a topic only related to LEDE as it is no problem to install the latest stable release of OpenWRT or even the trunk version. t doesn't matter if I try to install the factory image on top of the original version or upgrading from OpenWrt. Every time the system is entering a bootloop and is only accessible in failsafe mode.
Is there a way to debug which component in the image is causing this behaviour?

0 Likes

Bootloop after sysupgrade
#2

confirming the described bootloop problem on Archer C7 V1.1 using
lede-17.01.0-r3205-59508e3-ar71xx-generic-archer-c7-v1-squashfs-factory.bin

0 Likes

#3

I confirm it as well. Tried installing "releases/17.01.2/targets/ar71xx/generic/lede-17.01.2-ar71xx-generic-archer-c7-v1-squashfs-factory.bin" om TP-Link Archer C7 v1.1 and ended up in endless reboot loop.

1 Like

#4

Did you remove the radio?

I was getting stuck in a boot loop in LEDE, but not in OpenWRT (but Network->Wireless wasn't visible in LuCI). I checked dmesg in OpenWRT and was getting a kernel oops in ath10k_pci. The DD-WRT forums say that the radio needs to be removed for it to work, but it's not necessary for OpenWRT...

I tried removing the radio and everything's working fine - Network->Wireless shows up in OpenWRT, and LEDE isn't stuck in a boot loop.

0 Likes

#5

For me, OpenWRT installed fine but build was missing some components (IP-masq stuff) so everything worked fine but router was not routing (no NAT). LEDE build just bricked the router.'

I never tried removing the radio.

0 Likes

#6

Hi, my Archer c7 v1 is in boot loop after installing "lede-17.01.4-ar71xx-generic-archer-c7-v1-squashfs-sysupgrade"
Anyone can help me to unbrick my device?
I'm reading a lot of post on Tftp, serial etc... but without results.
Thank you.

0 Likes

#7

I am also experiencing this "boot loop" problem when I performed system upgrade using (lede-17.01.4-ar71xx-generic-archer-c7-v1-squashfs-sysupgrade.bin) on my TP-Link Archer C7 V1.1. Any Solution to this problem?

0 Likes

#8

I have Archer C7 V1. I am unable to flash LEDE 17.01.4 or OpenWRT 15.05.1. I have tried both the TP-Link web interface and I have tried the TFTP method. Each time it just bricks my router. However, then I am able to flash back the TP-Link stock firmware. Does anyone have any particular tips that could help? Thanks

0 Likes

#9

There is no driver for the 5GHz network available. So you have to open your router and unplug the card, then it will boot normal. You can replace it with a card from an old notebook.
I apologize for my bad English I'm an Austrian!

0 Likes