Problem in install uap AC Pro GEN2

Hello All
I have Unifi AP AC PRO which the version is 6.5.28,
I downgrade 5.43.35 by fwupdate.real -m /tmp/ubnt.bin, it's working.

I upload BZ.qca956x.v3.7.58.6385.170508.0957.bin to the router (192.168.1.20) and rename the *.bin to ubnt.bin then ,
fwupdate.real -m /tmp/ubnt.bin
UAP-AC-Pro-BZ.5.43.35# fwupdate.real -m /tmp/ubnt.bin
Invalid version 'BZ.qca956x.v3.7.58.6385.170508.0957'
"I think it's not work by this way"

there is other post in
firmwareloader_uap_ac_pro/README.md 位于 main - firmwareloader_uap_ac_pro - Codeberg.org
I just downlad the firmwareloader-win.exe
and rename the BZ.qca956x.v3.7.58.6385.170508.0957.bin to firmware.bin

waiting for the ssh connection to become ready
starting!
determine kernel and boot-selector dev
invoking cat /proc/mtd | awk -F ':' '/"kernel0"$/{ print substr($1,4)}' on AP..done!
invoking cat /proc/mtd | awk -F ':' '/"bs"$/{ print substr($1,4)}' on AP..done!
scp the firmware ... done!
removing write protection
invoking if [ -f /proc/ubnthal/.uf ]; then echo '5edfacbf' > /proc/ubnthal/.uf; fi on AP..done!
writing firmware to /dev/mtdblock"2\n" and setting /dev/mtd"4\n" to boot from itinvoking dd if=/tmp/firmware.bin of=/dev/mtdblock2
on AP..done!
invoking dd if=/dev/zero bs=1 count=1 of=/dev/mtd4
on AP..done!
invoking reboot on AP..done!
rebooting
firmware flashed successfully

after it reboot
UAP-AC-Pro-BZ.5.43.35#

need help.

Hi all,

I have the exact same issue.
I tried all solutions from OpenWrt AND Ubiquiti website ... without succes.

If someone who have install Openwrt on Unifi AP AC Pro GEN2 hardware can help us ?

Thank you in advance.