Problem flashing the Xiaomi Redmi Router AC2100

Hello,
I would like to flash my Xiaomi Redmi Router AC2100 but I can't get any further.
When I try to run the python pppoe-simulator.py I already get an error.

 sudo python pppoe-simulator.py
python: can't open file 'pppoe-simulator.py': [Errno 2] No such file or directory

As system I use a MX-19.2_x64 base: Debian GNU/Linux 10 (buster)

Are you in the directory where the file pppoe-simulator.py is located?

Now I have that when I run the sudo pyhton pppoe-simulator.py

Well I'm not a phyton expert. But I would try a more recent version. 2.7 is quite old. Either update on your Debian 10 (testing) or choose a more recent Ubuntu.

Once you do have the simulator file, but find it crashes with a Python error, that is likely because it is written for python v3. Most systems have both python 2 and python 3 installed. Use the command python3 instead of python.

Python3 is also used in the video tutorial. (Did I miss that? :blush: :grin:)

But how do I do that with the busybox?

He's not telling me any connection

Well this is a very thight description where everything this guy is talking/doing is important.
My guess is you missed the part with the server you have to setup to upload the busybox image/script. Which is needed at ~3:10 min. The server setup is mentioned for 2 seconds at ~2:03 min. :wink:

My mistake was to put the SimpleHTTPServer port before the file.
OpenWrt is now running on the Xiaomi Redmi Router AC2100
But how to get behind an existing router via SSH on the Router :thinking: :thinking:

If you've solved the install problem please close this topic and start another one for usage questions.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

I wish I could but I can't edit the first post

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.