Problem creating mesh with Archer C7 v2

I'm having a problem creating a mesh network with an Archer C7 v2 & TL-WDR3600 v1. AFAIK I've set them both up with the same wireless & mesh config on their 5GHz radio, the mesh interface comes up on the WDR3600 but not the Archer C7. The wireless network comes up for the Archer C7, but not the mesh interface. I also tried the mesh on the 2.4GHz radio but had the same result.

They're both running OpenWrt 2022.03 with wpad-mesh-wolfssl 2022-01-16-cff80b4f-12.

Archer C7

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option txpower '17'
	option country 'US'
	option path 'pci0000:00/0000:00:00.0'
	option cell_density '0'
	option htmode 'HT20'
	option channel '48'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Van Houten'
	option key 'xx<same passwd as on WDR3600>xx'
	option encryption 'sae-mixed'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option htmode 'HT20'
	option country 'US'
	option channel 'auto'
	option txpower '23'
	option path 'platform/ahb/18100000.wmac'
	option disabled '0'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Bouvier'
	option encryption 'psk2'
	option key 'xxpass1xx

config wifi-iface 'mesh'
	option device 'radio0'
	option mode 'mesh'
	option ifname 'mesh0'
	option encryption 'sae'
	option mesh_id 'rc-mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'lan'
	option key 'xx<same mesh passwd as on WDR3600>xx'

WDR3600:

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Krustyland'
	option key 'xxpass0xx'
	option encryption 'sae-mixed'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'`	
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'HT20'
	option country 'US'
	option cell_density '0'
	option channel '48'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key 'xx<same passwd as on Archer C7>xx'
	option ssid 'Van Houten'
	option encryption 'sae-mixed'

config wifi-device 'radio2'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option cell_density '0'
	option channel 'auto'
	option country 'US'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'gauley'
	option key 'xxpass2xx'
	option encryption 'sae'
	option disabled '1'

config wifi-iface 'mesh'
	option device 'radio1'
	option mode 'mesh'
	option ifname 'mesh0'
	option encryption 'sae'
	option mesh_id 'rc-mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option network 'lan'
	option key 'xx<same mesh passwd as on Archer C7>xx'

Archer C7 devices:

# iw dev
phy#1
	Interface wlan1
		ifindex 25
		wdev 0x100000007
		addr a4:2b:b0:a5:31:15
		ssid Bouvier
		type AP
		channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
		txpower 23.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcoltx-bytes	tx-packets
			0	0	64	0	0	0	0	11246		64
phy#0
	Interface wlan0-1
		ifindex 26
		wdev 0xd
		addr a6:2b:b0:a5:31:14
		ssid Van Houten
		type AP
		channel 48 (5240 MHz), width: 20 MHz, center1: 5240 MHz
		txpower 17.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcoltx-bytes	tx-packets
			0	0	7436	0	0	0	0	1461358		7436
	Interface mesh0
		ifindex 24
		wdev 0xc
		addr a4:2b:b0:a5:31:14
		type mesh point
		txpower 0.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcoltx-bytes	tx-packets
			0	0	0	0	0	0	0	0

WDR3600 devices:

# iw dev
phy#1
	Interface wlan1-1
		ifindex 27
		wdev 0x10000000f
		addr c2:4a:00:38:d2:6e
		ssid Van Houten
		type AP
		channel 48 (5240 MHz), width: 20 MHz, center1: 5240 MHz
		txpower 14.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcoltx-bytes	tx-packets
			0	0	0	0	0	0	0	0
	Interface mesh0
		ifindex 25
		wdev 0x10000000e
		addr c0:4a:00:38:d2:6e
		type mesh point
		channel 48 (5240 MHz), width: 20 MHz, center1: 5240 MHz
		txpower 14.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcoltx-bytes	tx-packets
			0	0	7471	0	0	0	0	1587694		7471
phy#0
	Interface wlan0
		ifindex 26
		wdev 0x6
		addr c0:4a:00:38:d2:6d
		ssid Krustyland
		type AP
		channel 1 (2412 MHz), width: 20 MHz, center1: 2412 MHz
		txpower 19.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcoltx-bytes	tx-packets
			0	0	0	0	0	0	0	0

Please try ath10k and the corresponding non-ct firmware, iirc -ct doesn't like meshing on wave1 hardware.

1 Like

That was it, thanks!

FYI, ath10k-firmware-qca988x now also installs ath10k-board-qca988x.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.