Problem compile

Hi everyone, First I don’t know if it goes in this forum section. I’m starting with the Openwrt. I have 3 routers that I want to put openwrt to. I am guiding myself to install openwrt starting from 0 with trunk. I have knowledge in linux but I have a big problem when compiling my openwrt with trunk. I am doing it from a virtual machine. I got the repository from github from the dev.Openwrt.org. page where it puts trunk. Everything well when updating until it reaches telephony/kamailio.5.x tells me that a dependency is missing in python-light. I do not know how to install this package. Well, it gives me trouble in that package and in compiling.

After upload capture of problem.

Thk you

It's a feed update "notice" and does not cause issues unless your using that package...

I'm not sure if it's the problem you are having but i counld not get the current master to compile after the update to the new kernel
i found i could not get debian 10.2 or 10.3 to compile
but linix mint worked
so if you are trying with basic debian try linux mint

Try auto-compiling on github :yum:

2 Likes

Yeah, I got linux mint. I’ll try from there.

You have a manual to do it directly from github? Manual or video. I have no idea.


usind command "make".

the 2 something about permits

And as you can see, they don’t allow the compilation to move forward
Here the errors that throw me when compiling

P.D: 3 images is not all followed

Do not compile as root, never.

As you've messed up your file access permissions already, delete your build tree again and start all over from scratch/ from git clone - no part of building OpenWrt requires root, su or sudo.

1 Like

I will prove what you are telling me. I will then publish results. Thank you.

If your routers are supported by OpenWrt, and you only want to use OpenWrt on them, you don't have to manually compile the firmware images from source. You can download a release, a snapshot, or use the Image Builder.

By the way, you should not login as root, sudo (or run anything) as root, unless:

  1. You understand the command and you know what you are doing
  2. The action does require root privileges (e.g. Installing packages via apt)

1° My idea is to have an openwrt to my liking from 0. With ftp server, which detects usb and its formats, to my language that is Spanish, download via torrent. That’s my idea of learning how to compile this.

2º I already did it yesterday without giving it root privileges and it follows the same problem.

Thank you

It will only complain about privileges if you use root... Using the root user, completely delete your current build tree, then start over again using a non-root user. If that fails, post the logs here. But, do not use images, copy the text instead, and paste it into a "preformatted text" block.

type Makefile:1110: recipe for target 'gimple-match.o' failed
make[5]: *** [gimple-match.o] Error 1
make[5]: Leaving directory '/home/david/openwrt/build_dir/toolchain-mips_24kc_gcc-8.4.0_musl/gcc-8.4.0-initial/gcc'
Makefile:4251: recipe for target 'all-gcc' failed
make[4]: *** [all-gcc] Error 2
make[4]: Leaving directory '/home/david/openwrt/build_dir/toolchain-mips_24kc_gcc-8.4.0_musl/gcc-8.4.0-initial'
Makefile:36: recipe for target '/home/david/openwrt/build_dir/toolchain-mips_24kc_gcc-8.4.0_musl/gcc-8.4.0-initial/.built' failed
make[3]: *** [/home/david/openwrt/build_dir/toolchain-mips_24kc_gcc-8.4.0_musl/gcc-8.4.0-initial/.built] Error 2
make[3]: Leaving directory '/home/david/openwrt/toolchain/gcc/initial'
time: toolchain/gcc/initial/compile#733.93#263.02#1145.91
toolchain/Makefile:98: recipe for target 'toolchain/gcc/initial/compile' failed
make[2]: *** [toolchain/gcc/initial/compile] Error 2
make[2]: Leaving directory '/home/david/openwrt'
toolchain/Makefile:96: recipe for target '/home/david/openwrt/staging_dir/toolchain-mips_24kc_gcc-8.4.0_musl/stamp/.toolchain_compile' failed
make[1]: *** [/home/david/openwrt/staging_dir/toolchain-mips_24kc_gcc-8.4.0_musl/stamp/.toolchain_compile] Error 2
make[1]: Leaving directory '/home/david/openwrt'
/home/david/openwrt/include/toplevel.mk:218: recipe for target 'world' failed
make: *** [world] Error 2
or paste code here

Este es el mensaje que arroja y no avanza con la compilación.

Actual error message is not shown here, you need to post more text.

I magically solved my problem, but now I have another problem. My intention is to create an openwrt for Observa Telecom VH4032N, now at the moment of compiling, it does everything well and once finished in the folder bin appears 2.2 gb of compiled for other routers. I want only for that router.