Problem: Can't setup EX3700; opkg update fails, can't install luci

I have a problem and I'm trying to learn.

I installed OpenWRT on a factory-reset Netgear EX3700. Used this image:

I connected via ethernet to my PC, ssh'd to, even set a root passwd, but the device apparently has zero internet access. I tried to "opkg update" but connection failed. I ping'd and get zero connection. I then plugged the EX3700 into my Comcast modem-router ethernet port, and tried to ssh to, but could not get a connection to the EX3700 from my PC. My PC has one ethernet port and is connected to internet via wifi only (comcast router is in another room).

The EX3700 is only a range extender that I happen to have. I'm trying to learn about OpenWRT and I'm considering buying a cheap router to install it on (e.g., TP Link Archer A7 v2, but I'll take suggestions!).

I'm guessing my best option to try to install a different image that would fix the problem (scp to /tmp and install somehow), unless there's a way to get internet access to the EX3700 with the current image installed.

Can anyone give me guidance??

As always, thanks for all your help.

This device has only one ethernet port, which by default is assigned to lan interface.
You'll need to change the IP so that it can connect to the ISP router, install luci and be able to configure it more easily.
Run the following commands:

uci set network.lan.ipaddr='X.X.X.X'
uci set network.lan.netmask=''
uci set network.lan.gateway='Y.Y.Y.Y'
uci set network.lan.dns='Y.Y.Y.Y'
uci set dhcp.lan.ignore='1'
uci commit
service dnsmasq restart
service network restart

X.X.X.X is a free IP address in the network of your ISP router, e.g
Y.Y.Y.Y is the IP of your ISP router, e.g
The mask is usually, but adapt it if it is different.

Thanks, I was really stoked when I saw your response.

But after I restart the network daemon, I can't login to the device. I tried to ssh into the new ip, the old ip, I tried setting different ip's. And from what I can tell, I set the correct gateway and dns ( I ran ipconfig on my PC, and it appears to say the gateway is Now, having said that, I do not believe the router itself is

I definitely appreciate your help. But I have no idea what's going on.

Edit..I was able to reset the device with the reset paperclip button, and log back in to the original ip of This is how I tried different settings.

The gateway and dns don't matter when you try to connect to the device from the same subnet.
After you make the above mentioned changes you must connect the router to the network of the ISP router, as well as the PC you use to connect, so both will get the correct IPs.

1 Like

That was exactly my issue with not being able to access the device after changing the device ip address. I did not even know what a subnet was, but now I have a better (tho imperfect) understanding.

Also, my original problem was me being a stupid human. Luci was already installed as a part of the image, and I was wrong to think I needed to install it via terminal/ssh. I thought it was not pre-installed because I was not getting a response when I browsed to the device ip address. However, it just took longer for Luci to get up and running than I thought. Impatience.

I also tried installing clamav to the EX3700 but not nearly enough storage space. Failed. Factory reset it, got it running again. I also went through some crazy nonsense trying to make the device function as a repeater. In reality, all I had to do was connect the EX3700 to the wifi signal I wanted to repeat, and then setup its own wifi signal. That's it. After that, it just worked. I forget what I had to do with the interfaces, but those did have to be set correctly.

I also bought the Archer A7 v5 (not C7), and installed OpenWRT to it. Added clamav and simple adblock, but I guess there was some error with simple adblock failing to download the lists over https/ssl. I installed openssl nginx, and now login to the A7 over https, but I beleive it is not exposed outside the subnet. And I installed the "real" wget, still trying to figure out what the problem is.

Next step is trying to get some firewall rules set up on A7, I guess.

And maybe I will eventually buy a pfSense box and put it in between the A7 and the cable modem, but I just don't see the point right now. I'm not seeing what pfSense offers me over OpenWRT.

maybe this thread can be closed, but I gotta say this.

I totally borked my router, I did: rm -r /overlay/upper and work. rebooted. and everything was crap. somehow I did a factory reset, which was a pain bc I thought LAN1 port was same as WAN port on the router. I'm not a smart human, what can I say.

But this made me want to expand storage with extroot. So I did. Plugged a usb drive with 1GB for extroot, 1GB as swap, and rest for data as ext4 partition. I just used the guide here (as well as youtube vids):

Duuuude, when I logged in to Luci and clicked software from the menu and saw free space = 99% 1.0GB, I straight up giggled like a 12 year old girl. My wife heard me and hasn't looked at me right for an hour. I love it.

1 Like

Best way to reset to defaults, if not from Luci menu, is command firstboot
Other than that I am glad you got it all working and the smile got back to your face after all the frustration. Take it slowly and you'll get the grasp of OpenWrt, we all started with little to no knowledge.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.