[probably solved] How to build on debian 9? Missing libpam, libgnutls,

Hi, I'm trying to build on debian 9 and I have some missing dependencies. Old wiki is read only and outdated, new wiki is not at all, can you please help me what I need to apt install on debian 9? I have installed those recommended for debian 8, but it's not enough.

When I run ./scripts/feeds/install -a I get this:

WARNING: Makefile 'package/utils/busybox/Makefile' has a dependency on 'libpam', which does not exist
WARNING: Makefile 'package/utils/busybox/Makefile' has a build dependency on 'libpam', which does not exist
WARNING: Makefile 'package/network/utils/curl/Makefile' has a dependency on 'libgnutls', which does not exist
WARNING: Makefile 'package/network/utils/curl/Makefile' has a dependency on 'libopenldap', which does not exist
WARNING: Makefile 'package/network/utils/curl/Makefile' has a dependency on 'libidn', which does not exist
WARNING: Makefile 'package/network/utils/curl/Makefile' has a dependency on 'libssh2', which does not exist
WARNING: Makefile 'package/boot/kexec-tools/Makefile' has a dependency on 'liblzma', which does not exist
WARNING: Makefile 'package/network/services/lldpd/Makefile' has a dependency on 'libnetsnmp', which does not exist

These libs come in different packages, so I tried to apt-get some, but still getting the same :frowning: Thanks.

Did you run "./scripts/feeds update -a" after cloning the source tree, before running that install script?

Hello, yes, surely did. Update does not display any warning, but install does.

Hi, it is strange, after clean git clone or make distclean it displays these warnings, but then I did update and install several times and now it does not display this warning :open_mouth:

You need to install the development packages for these libs.

i.e. on Fedora you'd have to install the RPM libssh2-devel, in order to compile something that uses libssh2.

Installing the package itself installs the binary for it, whereas installing the development for it installs the source it uses that's needed for compiling something that uses it.

i have the same probleme i have done my updates and now it's still showing the warning please is it going to disturb my works on openwrt?

same problem here.. on Ubuntu 18.04 LTS and 18.10 desktop

You're doing something wrong on your end most likely....

git clone https://github.com/openwrt/openwrt
cd openwrt
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig  --> Do changes --> Save config
make -j4 or whatever you prefer

Same problem here... Anyone has a solution?

Could it be that the 64bit base OS (like Ubuntu) doesn't have such libs anymore? This is mentioned in this post:

I tried to install manually using: sudo apt-get install libgnutls* on my base OS (Ubuntu)
However the previous error remains. Saying that libgnutls lib (and the other libs) is missing.

I can also find the libgnutls in my system:

/usr/lib/i386-linux-gnu/libgnutls.so.30
/usr/lib/i386-linux-gnu/libgnutls.so.30.22.0
/usr/lib/x86_64-linux-gnu/libgnutls-openssl.so.27
/usr/lib/x86_64-linux-gnu/libgnutls-openssl.so.27.0.2
/usr/lib/x86_64-linux-gnu/libgnutls.so.30
/usr/lib/x86_64-linux-gnu/libgnutls.so.30.22.0
/usr/lib/x86_64-linux-gnu/vlc/plugins/misc/libgnutls_plugin.so
/usr/share/doc/libgnutls-openssl27

Any idea on how to solve this error?
Thank you for your help.

gnutls-bin - GNU TLS library - commandline utilities
gnutls-doc - GNU TLS library - documentation and examples
libgnutls-dane0 - GNU TLS library - DANE security support
libgnutls-openssl27 - GNU TLS library - OpenSSL wrapper
libgnutls28-dev - GNU TLS library - development files
libgnutls30 - GNU TLS library - main runtime library
libgnutlsxx28 - GNU TLS library - C++ runtime library

One of these? Well that's debian.... The ubuntu support pages might get you a definitive answer...

Thank you for your input.
I did a fresh Ubuntu install and the problem remains.

I believe I do have the lib installed:

joao@mypc:~/openwrt/source$ locate libgnutls 
/snap/core/6350/usr/lib/x86_64-linux-gnu/libgnutls-openssl.so.27
/snap/core/6350/usr/lib/x86_64-linux-gnu/libgnutls-openssl.so.27.0.2
/snap/core/6350/usr/lib/x86_64-linux-gnu/libgnutls.so.30
/snap/core/6350/usr/lib/x86_64-linux-gnu/libgnutls.so.30.6.2
/snap/core/6350/usr/share/doc/libgnutls-openssl27
/snap/core/6350/usr/share/doc/libgnutls30
/snap/core/6350/usr/share/doc/libgnutls-openssl27/changelog.Debian.gz
/snap/core/6350/usr/share/doc/libgnutls-openssl27/copyright.gz
/snap/core/6350/usr/share/doc/libgnutls30/changelog.Debian.gz
/snap/core/6350/usr/share/doc/libgnutls30/copyright.gz
/snap/gnome-3-26-1604/74/usr/lib/x86_64-linux-gnu/libgnutls.so.30
/snap/gnome-3-26-1604/74/usr/lib/x86_64-linux-gnu/libgnutls.so.30.6.2
/snap/gnome-3-26-1604/74/usr/share/doc/libgnutls30
/snap/gnome-3-26-1604/74/usr/share/doc/libgnutls30/AUTHORS
/snap/gnome-3-26-1604/74/usr/share/doc/libgnutls30/NEWS.Debian.gz
/snap/gnome-3-26-1604/74/usr/share/doc/libgnutls30/NEWS.gz
/snap/gnome-3-26-1604/74/usr/share/doc/libgnutls30/README.gz
/snap/gnome-3-26-1604/74/usr/share/doc/libgnutls30/THANKS.gz
/snap/gnome-3-26-1604/74/usr/share/doc/libgnutls30/changelog.Debian.gz
/snap/gnome-3-26-1604/74/usr/share/doc/libgnutls30/copyright
/usr/lib/x86_64-linux-gnu/libgnutls.so.30
/usr/lib/x86_64-linux-gnu/libgnutls.so.30.14.10
/usr/share/doc/libgnutls30
/usr/share/doc/libgnutls30/AUTHORS
/usr/share/doc/libgnutls30/NEWS.Debian.gz
/usr/share/doc/libgnutls30/NEWS.gz
/usr/share/doc/libgnutls30/README.md.gz
/usr/share/doc/libgnutls30/THANKS.gz
/usr/share/doc/libgnutls30/changelog.Debian.gz
/usr/share/doc/libgnutls30/copyright
/usr/share/doc/libgnutls30/license.AGPLv3.gz
/var/lib/dpkg/info/libgnutls30:amd64.list
/var/lib/dpkg/info/libgnutls30:amd64.md5sums
/var/lib/dpkg/info/libgnutls30:amd64.shlibs
/var/lib/dpkg/info/libgnutls30:amd64.symbols
/var/lib/dpkg/info/libgnutls30:amd64.triggers
joao@mypc:~/openwrt/source$ 

Tried to add simbolic links to the libs that cant be found. The missing libs are all there!!!

Problem still not solved using symbolic links...

sudo ln -s /lib/x86_64-linux-gnu/lib*.so.* /usr/local/lib/

ls /usr/local/lib

joao@devops:~/openwrt/source$ ls /usr/local/lib/
libacl.so.1                libnewt.so.0.52.20
libacl.so.1.1.0            libnih.so.1
libanl.so.1                libnih.so.1.0.0
libapparmor.so.1           libnl-3.so.200
libapparmor.so.1.4.2       libnl-3.so.200.24.0
libatasmart.so.4           libnl-genl-3.so.200
libatasmart.so.4.0.5       libnl-genl-3.so.200.24.0
libatm.so.1                libnsl.so.1
libatm.so.1.0.0            libnss_compat.so.2
libattr.so.1               libnss_dns.so.2
libattr.so.1.1.0           libnss_files.so.2
libaudit.so.1              libnss_hesiod.so.2
libaudit.so.1.0.0          libnss_mdns4_minimal.so.2
libblkid.so.1              libnss_mdns4.so.2
libblkid.so.1.1.0          libnss_mdns6_minimal.so.2
libbrlapi.so.0.6           libnss_mdns6.so.2
libbrlapi.so.0.6.6         libnss_mdns_minimal.so.2
libBrokenLocale.so.1       libnss_mdns.so.2
libbsd.so.0                libnss_myhostname.so.2
libbsd.so.0.8.7            libnss_nisplus.so.2
libbz2.so.1                libnss_nis.so.2
libbz2.so.1.0              libnss_systemd.so.2
libbz2.so.1.0.4            libntfs-3g.so.88
libcap-ng.so.0             libntfs-3g.so.88.0.0
libcap-ng.so.0.0.0         libpamc.so.0
libcap.so.2                libpamc.so.0.82.1
libcap.so.2.25             libpam_misc.so.0
libcidn.so.1               libpam_misc.so.0.82.0
libcom_err.so.2            libpam.so.0
libcom_err.so.2.1          libpam.so.0.83.1
libcryptsetup.so.12        libparted-fs-resize.so.0
libcryptsetup.so.12.2.0    libparted-fs-resize.so.0.0.1
libcrypt.so.1              libparted.so.2
libc.so.6                  libparted.so.2.0.1
libdbus-1.so.3             libpci.so.3
libdbus-1.so.3.19.4        libpci.so.3.5.2
libdevmapper.so.1.02.1     libpcre.so.3
libdl.so.2                 libpcre.so.3.13.3
libdns-export.so.1100      libply-boot-client.so.4
libdns-export.so.1100.1.1  libply-boot-client.so.4.0.0
libe2p.so.2                libply.so.4
libe2p.so.2.3              libply.so.4.0.0
libexpat.so.1              libply-splash-core.so.4
libexpat.so.1.6.7          libply-splash-core.so.4.0.0
libext2fs.so.2             libply-splash-graphics.so.4
libext2fs.so.2.4           libply-splash-graphics.so.4.0.0
libfdisk.so.1              libprocps.so.6
libfdisk.so.1.1.0          libprocps.so.6.0.0
libfuse.so.2               libpthread.so.0
libfuse.so.2.9.7           libreadline.so.7
libgcc_s.so.1              libreadline.so.7.0
libgcrypt.so.20            libresolv.so.2
libgcrypt.so.20.2.1        librt.so.1
libgpg-error.so.0          libseccomp.so.2
libgpg-error.so.0.22.0     libseccomp.so.2.3.1
libhistory.so.7            libselinux.so.1
libhistory.so.7.0          libsepol.so.1
libidn.so.11               libslang.so.2
libidn.so.11.6.16          libslang.so.2.3.1
libisc-export.so.169       libsmartcols.so.1
libisc-export.so.169.0.1   libsmartcols.so.1.1.0
libiw.so.30                libss.so.2
libjson-c.so.3             libss.so.2.0
libjson-c.so.3.0.1         libsystemd.so.0
libkeyutils.so.1           libsystemd.so.0.21.0
libkeyutils.so.1.5         libthread_db.so.1
libkmod.so.2               libtinfo.so.5
libkmod.so.2.3.2           libtinfo.so.5.9
liblzma.so.5               libudev.so.1
liblzma.so.5.2.2           libudev.so.1.6.9
liblzo2.so.2               libulockmgr.so.1
liblzo2.so.2.0.0           libulockmgr.so.1.0.1
libmnl.so.0                libusb-1.0.so.0
libmnl.so.0.2.0            libusb-1.0.so.0.1.0
libmount.so.1              libutil.so.1
libmount.so.1.1.0          libuuid.so.1
libm.so.6                  libuuid.so.1.3.0
libmvec.so.1               libwrap.so.0
libncurses.so.5            libwrap.so.0.7.6
libncurses.so.5.9          libz.so.1
libncursesw.so.5           libz.so.1.2.11
libncursesw.so.5.9         python2.7
libnewt.so.0.52            python3.6

Looks like it could be related to that x386 libs thing.....

I remember a few years ago... and once or twice since ...

We had to install the 386 libs for alot of things to work on 64...... and the errors at the time were not so descriptive.... to me anyway... cause the system does some sort of translations beneath.....

( read the askubuntu link you posted above.... response 1 -> comment 1 )

Now the you've played with the links and stuff......

chances are your going have to do some major apt-get remove --purge etc. action to ensure the system "sees" the right things in the right places.

( this explains a bit about the underlying issues
https://support.archiware.com/support/index.php?/Knowledgebase/Article/View/108/16/errors-on-64-bit-ubuntu-linux

Who knows... maybe they went the other way and there is no need for the compatibility libs now..... and your system still references them / parts of them?

OpenWrt doesn't need i386 compatibility (multi-arch) libraries to build.

1 Like

Hello all,

I'm glad to report that the problem seems to be SOLVED.

The problem was that the tutorial I was following asked to create a file feeds.conf with

src-link mypackages /home/me/.../my_packages

When I did

./scripts/feeds update -a
./scripts/feeds install -a

it only updated and installed the package from the feeds.conf file.

All I needed to do was:

mv feeds.conf feeds.conf.old
./scripts/feeds update -a
./scripts/feeds install -a

Then installed some missing dependencies like perl, ... and VOILÁ... no more problems with libs!!!

2 Likes