Printing problem via p910nd Printer Server: "Processing - The printer is not responding."


after I've set up printing support according to printing worked just fine for one or two days. Now I get the error "Processing - The printer is not responding." sending a printing job.

Some setup information:

  • OpenWRT/LEDE version: Reboot (17.01.4, r3560-79f57e422d) (TP-Link tl-wr842nd)
# cat /etc/config/p910nd

config p910nd
	option device '/dev/usb/lp0'
	option port '0'
	option bidirectional '1'
	option enabled '1'
	option bind ''

I just noticed:

# dmesg
[515869.259726] usb 1-1: new high-speed USB device number 7 using ehci-platform
[515869.740207] usblp 1-1:1.1: usblp0: USB Bidirectional printer dev 7 if 1 alt 0 proto 2 vid 0x04B8 pid 0x08A8
[516572.178066] usb 1-1: USB disconnect, device number 7
[516572.184089] usblp0: removed
[516576.068380] usb 1-1: new high-speed USB device number 8 using ehci-platform
[516576.387619] usblp 1-1:1.1: usblp0: USB Bidirectional printer dev 8 if 1 alt 0 proto 2 vid 0x04B8 pid 0x08A8

...after unplugging the printer. Is it a problem that the device number is counting up?

Doesn't look like the source for p910nd has been updated in over four years, so that's a potential issue.

Do you see /dev/usb/lp0 being created?

I've never used p910nd, but in case it helps, I'd check and see if there's any difference between when the printer is "awake" when you try to print and when the printer is in sleep/energy saver mode.

Thx for your help, yes it is created:

root@LEDE:/# ls -la /dev/usb/
drwxr-xr-x    2 root     root            60 Jun 21 22:51 .
drwxr-xr-x    5 root     root          1160 Jun 14 14:38 ..
crw-------    1 root     root      180,   0 Jun 21 22:51 lp0

Thx for your reply, too.

I've checked printing a test page and the error message is the same.

Well, I wanted to use CUPS but according to I have to compile it. I'm quite new to OpenWRT/LEDE and didn't want to try an extra hard way... are there other options beside p910nd and CUPS?

Not a fix I'm afraid, I just joined the forum today 14th July 2018.

I have p910nd print server installed on OpenWRT on a TP-Link WR703N single Ethernet port and single USB port.

I have installed and enabled p910nd as per the OpenWRT instructions and created a printer in Windows with the IP address of the router and port 9100 and I have edited the router firewall to allow traffic to the USB port.

I have the 703 connected to my broadband router via Ethernet, which gets me Internet connectivity to install packages on the 703........ like p910nd and nano.

Printing fails and has never worked, the job appears in the Windows printer queue sits there for a minute or two and then I get an error message. Connection is USB (obviously)

I'm new to both Linux and OpenWRT and so have dozens of searches open and have tried lots of things, the config file which seems to be the critical aspect I get is..

config p910nd
option device '/dev/usb/lp0'
option port '0'
option bidirectional '1'
option enabled '0'

(I don't get the ' ' quotes which I assume is the PuTTY interface or a difference in config of OpenWRT but I guess what I have is correct)

It is the "option enabled 0" that is I assume the problem???

I have reinstalled p910nd enabled and started it but it never appears as "enabled 1"

Before I go too far and change too many things can anyone say definitively that having enabled as 0 is a problem (possibly THE problem)?

If it is the problem I seem to have done everything by the book so would appreciate knowing how to enable it............. is this just editing a file?

Happy to supply versions of whatever needed, some info on how to get these version may be necessary and save time.

I don't get a printer is not responding message, simply the error message in the Windows print queue.

dmsg on USB gives me..

usb 1-1: new high-speed USB device number 2 using ehci-platform
usblp 1-1:1.1: usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x03F0 0xB111

Thanks in advance..

Yes, you need to change 0 to 1.

Quite new to Linux and OpenWRT.

Is the change editing a file or issuing a command?

I have tried all the commands installing, p910nd I can find

If it's a file please let me know which one.

You either edit /etc/config/p910nd with an editor of your choice ("busybox vi" being the default) or tick the corresponding checkbox in luci, which does the same (or invoke the equivalent uci command, or, or ...)

In your first post it was set to 1 one what happened.

You can edit the config file with vi.
vi /etc/config/p910nd

1 Like

If the pre-installed vi is unfamiliar to you, assuming you have room on your device, many find nano to be an easier editor to learn.

opkg update
opkg install nano

or install through LuCI.

Installed nano, and edited the config file.

(I have piggy backed on the original post {trying to keep the p910nd stuff in one place} which is why the enable was "1" in a previous post i.e. not mine.)

No change when I edited and put "enable 1", also disabled the Windows anti-virus and firewall, again no change.

Have seen a utility "lsusb" but this isn't installed and opkg install lsusb gets .... Cannot install package"

I'm looking for a way to check communication to the USB port as a way to check in stages if anyone has an approach for this?


opkg update
opkg install usbutils

Thanks... the 703 has just run out of space 136kb left usbutils needs 201


Now to find out what and how to remove packages

I had just found ..
which has several pages on USB drivers and troubleshooting but the limited RAM on this device is now a problem.

If they're built into the image, "removing" them doesn't free up any space. (They're in the read-only squashfs, with "Wite Out" on the overlay file system hiding them.)

If you can't remove enough of the packages you installed yourself after you flashed it, then you'd likely need to build your own image.

Plus likely at least 64 kB of space for "erase blocks" for how the flash-based file system works.

Just checking if I can remove nano and if that will give me enough space. I managed with edlin for years with DOS and so I guess vi or vim can't be too bad. Will try a Windows based version for some practice.

I hadn't planned on a new image design just yet ! :slight_smile: maybe I will find another router with a USB port and a little more memory as a backup to this.

Has anyone ever added RAM to an old router? Seems like newer designs have less RAM than older ones. I guess there are at least two parts to this as the image will be flashed to a EEPROM?

Name: nano
Version: 2.9.8-1
Size: 58389
Description: Nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone of the Pico text editor.

136 + 58 = 194, a bit short of 201, not to mention spare empty blocks

Other than a custom build it seems like a 32 to 64 MB increase in RAM, there are a few videos describing this.

I think I found the problem: It seems like the USB port goes into standby if unused for a while. I could wake the USB port up again via LuCI -> Services -> p910nd - Printer server -> checking "Bidirectional mode", save&apply, unchecking "Bidirectional mode" again, save&apply.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.