Printer with 2 radios 2.4 and 5 GHz ( not access )

hi

I have a problem, I will try to be clear, because English is not easy for me.

I have a router with 2 ssid: net.2.4ghz and net.5ghz.
my lan uses the address 10.0.0.1 with 0.2 to 0.99 in static then to 10.0.0.100, I switch to dynamic DHCP.

I have a wifi printer connected on the 2.4ghz network with address 10.0.0.5.

on my phone, if I'm connected on 2.4ghz network, I can't access to the web interface of the printer, but, if I'm connected on 5ghz wifi, then I can access to the interface ( worked if my phone is connect to 5ghz ) .

It does the same thing on my pc.


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.0.0.1'
	option ipv6 '0'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'
	option ipv6 '0'

config switch
	option name 'switch0'
	option reset '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4'
	option vid '1'

config device
	option name 'wlan_Net_5ghz'
	option ipv6 '0'

config device
	option name 'wlan_box_2.4ghz'
	option ipv6 '0'


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option ednspacket_max '1232'
	list server '10.0.0.1#5335'
	option sequential_ip '1'
	option localservice '1'
	option nohosts '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option dhcpv4 'server'
	option leasetime '72h'
	list ra_flags 'none'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option name 'WIFIasusN76VB'
	option dns '1'
	option mac '6C:71:D9:AC:18:1D'
	option ip '10.0.0.3'

config host
	option dns '1'
	option ip '10.0.0.4'
	option name 'RN8Pseb'
	option mac 'A4:4B:D5:C8:D3:5C 1C:65:9D:61:53:7B'

config host
	option name 'RN8Palice'
	option dns '1'
	option mac 'FC:19:99:D1:C2:1C'
	option ip '10.0.0.11'

config host
	option name 'TabletteM5alice'
	option dns '1'
	option mac 'B4:CD:27:36:A9:13'
	option ip '10.0.0.12'

config host
	option name 'ACERalice'
	option dns '1'
	option mac '1C:65:9D:61:53:7B'
	option ip '10.0.0.10'

config host
	option name 'firestickChambre'
	option dns '1'
	option mac 'A4:08:01:F6:09:29'
	option ip '10.0.0.21'

config host
	option name 'xiaomi3Hsalon'
	option dns '1'
	option mac '54:48:E6:BA:07:DD'
	option ip '10.0.0.30'

config host
	option name 'Firesticksalon'
	option dns '1'
	option mac 'D8:BE:65:8D:D9:A1'
	option ip '10.0.0.22'

config host
	option dns '1'
	option mac 'F4:39:09:8F:08:BF'
	option name 'hp2620'
	option ip '10.0.0.5'



config wifi-device 'radio0'
	option type 'mac80211'
	option channel '100'
	option hwmode '11a'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/soc/a000000.wifi'
	option cell_density '0'
	option htmode 'HT40'
	option txpower '17'
	option country 'FR'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Net_2.4ghz'
	option ifname 'wlan_box_2.4ghz'
	option skip_inactivity_poll '1'
	option disassoc_low_ack '0'
	option encryption 'psk2'
	option key 'scott2005'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'platform/soc/a800000.wifi'
	option htmode 'VHT80'
	option country 'FR'
	option cell_density '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'Net_5ghz'
	option ifname 'wlan_Net_5ghz'
	option skip_inactivity_poll '1'
	option disassoc_low_ack '0'
	option encryption 'psk2'
	option key 'scott2005'


do you have idea ?

thank you

i don't know why dosen't work

What is the model of router ?
What is version of OpenWrt installed ?

Can you ping the printer's IP address from iphone on 2.4 and 5 GHz?
Can you ping the printer from the router?

Do you have any other device on 2.4 GHz with static or DHCP address?
Can you ping it from router and phone on 2.4 and 5 GHz?

on 2.4 ghz, ping fail
on 5 ghz is possible for me access on web interface ( work on 5 ghz )

from the router, no problem for ping and trace.

ping router adresse on 2.4ghz ( ping 10.0.0.1 ) no problem

my router is linksys EA8300 OpenWrt 21.02.0-rc3 r16172-2aba3e9784

very difficulte for me know why don't work :confused:

What is model of printer?

Does the printer acquire an IP address from router if you change it to use DHCP?

Have you considered using stable 19.07.5 or later?

Your routeur has an USB port: why don't you install a printer server and plug the printer ? Simple, efficient, no wifi to configure, high bandwith, available everywhere on your LAN.

If I remove the static IP in .5 then it will take the IP 10.0.0.100, so I guess DHCP works fine.

For the downgrade, I would like to not do it if I can find a solution.

For the USB cable, it is not possible in my current configuration of the rooms in the house.

the printer is HP 2620

Can you ping the printer from 2.4 and 5 GHz with its temporary DHCP IP address?

yes no problem :
i have remove static lease

PING 10.0.0.100 (10.0.0.100): 56 data bytes
64 bytes from 10.0.0.100: seq=0 ttl=255 time=45.032 ms
64 bytes from 10.0.0.100: seq=1 ttl=255 time=42.982 ms
64 bytes from 10.0.0.100: seq=2 ttl=255 time=75.720 ms
64 bytes from 10.0.0.100: seq=3 ttl=255 time=40.351 ms
64 bytes from 10.0.0.100: seq=4 ttl=255 time=54.477 ms

--- 10.0.0.100 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 40.351/51.712/75.720 ms
traceroute to 10.0.0.100 (10.0.0.100), 30 hops max, 38 byte packets
 1  10.0.0.100  37.233 ms
Server:		127.0.0.1
Address:	127.0.0.1#53

100.0.0.10.in-addr.arpa	name = HP8F08BF.lan

on 2.4ghz

on 5ghz :

ok i found the problem, but i don't know why...

on this page :

the interface name on 2.4ghz configured to " net_2.4ghz "
and on 5 ghz configured to "net_5ghz"

and no work, but, if me no change and use only "vlan1" and "vlan2"
worked ok.

why ?

The default interface name is blank on 21.02.0-rc4 on my HH5a device for both 2.4 and 5 GHz wireless interfaces.

Did you originally add the interface names, **net_*ghz ?

0ssid

because...

no realy no reason, juste i think is easy for me found later on the file or other log.
realy no reason

for the wirless 2.4, i have rename 2.4 ^^

and for me ( noob ) is strange because for me, BR_lan have printer and brlan redistribute the 2 network ...

is solved, but i don't know why is important blank name

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.