Preblem with my small home LAN

Greetings.
I'm having a problem in my small home LAN that I want to share with you, in the hope that someone can help me find the solution.
The network is made up as follows:

  • carrier router
  • TPLink TL-WR841N Access Point with original firmware
  • TPLink TL-WR841N access point with OpenWrt firmware
    OpenWrt 18.06.9 r8077-7cbbab7246 / LuCI openwrt-18.06 branch (git-20.319.49209-ab22243)

The third device is the one designated as DHCP for the entire network.

I wanted to use some screenshots to better clarify the situations but the board won't let me.
Let's do like this:

config dnsmasq
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '0'
	option nonwildcard '0'
	option authoritative '1'

config dhcp 'lan'
	option interface 'lan'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option start '61'
	option limit '100'
	option leasetime '12h'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option dns '1'
	option mac [cut]
	option ip '192.168.0.101'
	option name [cut]

[cut]

Let's see the wireless side...

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca953x_wmac'
	option htmode 'HT20'
	option legacy_rates '1'
	option country 'IT'
	option disabled '0'
	option channel '2'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid [CUT]
	option encryption 'psk2'
	option key [CUT]
	option network 'lan'
	option macfilter 'allow'
	list maclist [cut]

Here… I think I have shown you the most important parameters.
PROBLEM N° 1
Wifi devices with a dynamic IP address are often assigned an IP outside the above range.


PROBLEM N° 2
Let's start with this scenario

  • router turned on and its associated Wi-Fi devices turned on
  • Original AP off with its associated devices on (I can't do otherwise!)
  • AP OpenWRT turned on with its devices turned off.
    The situation is correct.
    The static IPs assigned to the devices paired with the router by DHCP are consistent with those set by me.
    I turn on the original AP.
    The static IPs assigned by DHCP to the devices paired with the AP are consistent with those set by me.
    I turn on the devices assigned to the OpenWRT AP.
    The static IPs assigned by DHCP to the devices paired with the AP are consistent with those set by me.
    Everything OK! So where is the problem?

It's been a while...

All devices managed by the "original" AP (and only those) are gone.
Every now and then in a random way one of them peeps into the Wireless network watcher interface
Disappeared from the network but... perfectly functional with the proprietary Apps.
So on the network there must be!
Example my IPCams are perfectly visible from the App but are not found by iSpy.
When visibiles in Wireless network watcher all cameras are OK!
I specify that almost all of the devices managed by DHCP are IoT devices.

Thanks for your attention.

About #1: the limit parameter is not the upper limit, but the size of the pool. Your devices will get addresses from .61 to .161.

About #2: I could not understand the situation in full, but I think your devices are jumping from one AP to the other, and you are seeing them only on the AP where you are looking for them.

Thank you for your attention.
Resolved!

DHCPs of router and original AP are disabled.
If you need more details, just ask!

If it can be useful, I inform you that in the "Active DHCP Leases" section all the router and APs devices are shown with the correct IP address

A home network must have only one DHCP server active on it. Otherwise the two servers will give out conflicting information.

Sorry where did you find written that in my network there are more than one active DHCP?

A router with stock firmware will have a DHCP server active. In order to use it as a dumb AP, you must disable that server. Most stock firmware does have that option.

My router and AP original DHCP

I do not see the relation between DHCP and the issue you experience (again, if I understand you correctly). Clients to one AP are only "clients" to that AP, and they will not appear as clients on other APs in your network.

Probably not related to your issue, but consider upgrading to a newer release if possible or otherwise replace it with newer HW. There may be unpatched security flaws in that version as it does not receive any security patches anymore.

1 Like

Me niether.
I've reported the update for clarification to rule out a DHCP problem.
The AP sees and manages all hardware on the network

The problem is that it doesn't appear on the network (not on another AP) even though it is there.

Not possible :sleepy:

I will evaluate in the future... :thinking:

Can you clarify/confirm the following:

  • Are the secondary routers (the two TP-Link devices) connected via their lan ports to the carrier router? (this would setup a lan-lan physical topology)? Or is one or the other (or both) connected using its wan port?
  • When you talk about static IPs, are these actually manually configured static IPs (i.e. set as static on the hosts themselves), or are these DHCP reservations?
  • Gone from what? The list of wifi clients? DHCP leases list? something else?
  • How does iSpy look for cameras? Is it using mdns? IP addresses? network scans? Some other method?

  • Can you ping the cameras (and any other affected devices) when they are not showing up on the "original AP" listing?

1 Like

All AP are connected to the router via lan switch. Not use WAN port.

DHCP reservations

They are no longer visible on the network. If I scan my LAN with Wireless network watcher (WNW) they are no longer visible.
But they are there because the devices work with proprietary apps.
It is not a problem of WNW because not even iSpy (for example) sees the IPCams when it doesn't see them in WNW.

IPs

No. But from the proprietary App I can see the camera without problems

I would recommend resetting your openwrt router to defaults and then making the minimum necessary changes to the config to make it work (I.e the wireless country code, ssid, encryption, password management settings, dhcp reservation list, ip address of the device itself). Don’t use the MAC filter. Keep the changes to only those that are truly required.

See if that helps.

(Make a backup first, of course, then you can always restore in the event that you need to).

Please double to triple check this. A lan-wan connection would absolutely explain the observed situation. Likewise, make sure that nothing else other than these 3 devices are broadcasting the ssid that is in use here.

I take this opportunity to ask you a stupid question to which (I hope) I already know the answer:
If my FOR EXAMPLE:
SSID= Hello
Psw= Hello
encryption=WPA2
When I reset the AP and re-enter the above parameters, are all the devices recognized or do they have to be repairing one by one?

What if the router is from another brand?

I left for a short vacation.
I'll check on Tuesday and let you know.

Each AP has its own SSID which is different from the others.

Thank you all for the time you have dedicated to me.