Pre-compiled updated mwlwifi drivers for stable releases

@eduperez, please build mwlwifi driver version 10.3.8.0-thagabe commit 93c3d8d for 19.07.4. I will be using it on my WRT3200acm.

Thanks!

Yes, sure, just give me a couple of days!

1 Like

How about drivers built for OpenWRT 19.07.4 too? :slight_smile:

@eduperez

I am having issues as stated in forum post: WRT3200ACM on 19.07.4 DFS not Working

Will a 19.07.4 package of yours potentially fix my issue?

Your support in keeping the rest of us updated with mwlwifi drivers is greatly appreciated.

Packages for 19.07.4 with Thagabe's patches available at:

I see your issue has been fixed, following the instructions at SOLVED: WRT3200ACM on 19.07.4 DFS not Working.

There is another workaround, that enables to change the country on the third radio: https://github.com/kaloz/mwlwifi/issues/280#issuecomment-580008509.

1 Like

Thanks for the information. I have not had a need for the third radio so far so will remain with the removal of the related packages but if that changes, I will try your solution.

Many thanks.

1 Like

kmod-mwlwifi_5.4.66+thagabe-93c3d8d1 - wrong kernel

Firmware packages for 19.07.3 and 19.07.4 are exactly the same, and have exactly the same name; but "opkg" detects they belong to different version and refuses to install them.

You can force the installation, or you can wait another "couple of days" untill I upload a net built.

i tried as usual - opkg install --force-downgrade. kmod-mwlwifi refused to install. there was indicated a mismatch in dependencies.

@eduperez, thank you for the builds. But, I'm seeing the same issue as SuperMouse:

root@LEDE:/mnt/sdb2/ver# opkg install --force-downgrade kmod-mwlwifi_5.4.66+thag
abe-93c3d8d1-1_arm_cortex-a9_vfpv3-d16.ipk
Upgrading kmod-mwlwifi on root from 4.14.195+2019-03-02-31d93860-1 to 5.4.66+thagabe-93c3d8d1-1...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-mwlwifi:
 *      kernel (= 5.4.66-1-039441143c93c877759652dcaf71e152)
 * opkg_install_cmd: Cannot install package kmod-mwlwifi.

I see, I will have to rebuild the packages.

I have uploaded new packages for 19.07.4.

i got same error.

Upgrading kmod-mwlwifi on root from 4.14.195+2019-03-02-31d93860-1 to 5.4.66+2020-07-29-93c3d8d1-thagabe...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-mwlwifi:
 *      kernel (= 5.4.66-1-039441143c93c877759652dcaf71e152)
 * opkg_install_cmd: Cannot install package kmod-mwlwifi.

looks like that is for 5.4 .66 kernel

Looks like this idiot compiled the packages against snapshot instead ofthe latest release... will update new packages as soon as possible.

1 Like

don't say that, a distraction can happen to everyone. you helped openwrt a lot with drivers.

@eduperez i cannot find the drivers for that kernel anymore, for 5.4 .66, if that is not a problem, can you upload that if you still have it?
firmware and driver for wrt 3200, i want test the thagabe version.

I took the packages down to avoid confusions, I will upload them again, no problem.

1 Like

I have just restored the packages for the latest SNAPSHOT :slight_smile:

Packages for 19.07.4 will come shortly, this time for real, I promise... or maybe not :wink:

I need to come up with a better naming scheme for the files, because the firmware packages are essentially the same for all versions of OpenWrt, but they have different dependencies, and must have different names. I open to ideas here :thinking:

2 Likes

Packages for 19.07.4 are also available now. Please, be careful when downloading the packages for your version of OpenWrt; it is very easy to confuse the names, I know.

2 Likes