PPTP GRE firewall problem

I'm new here, so hello!

I have 18.06 on 1900ACS v2, one problem, i'm runing wan with fixed IP and pptp vpn with fixed ip network.

All good when on wan zone input is accept, but once i set input on wan as reject i have problem with connection. log rejects GRE protocol then. I tried lot of firewall settings, tested by opening/closing ssh or another ports, so looks firewall itself works correctly, but no matter what rule i make, it won't pass GRE, i tried also iptables, ipening 1723 port won't help.
PC's with pptp separate clients can connect even if wan input is set as reject.

Error i'm getting:
Thu Sep 27 09:44:10 2018 kern.warn kernel: [25679.479676] REJECT zonewan in: IN=eth1.1 OUT= MAC=xxxxxxx SRC=VPNPROVIDERIP DST=WANIP LEN=92 TOS=0x00 PREC=0x00 TTL=110 ID=28014 PROTO=47

What rules are you using to open GRE (remember it is a protocol, not a port)?

Also install kmod-ipt-raw to enable PPtP conntrack helpers.

I was using rules by zone, by ip it shows in logs, and yes, as protocol, I was typing there 47 and also tested with gre in that field. I'll check kmod ipt raw

Perhaps you could share your config files here.

OK, i installed kmod-ipt-raw and added rule "source zone wan, protocol 47, destination zone Device Input, accept" and it works!