PPtP Client not starting on 17.01.4

Hello,

I'm having a bit of an odd issue with my LEDE installation. I have a Mikrotik RB750GL and up to this point it had been running 15.05. Today I decided to bite the bullet and have a crack at upgrading it.

The upgrade process went smoothly and I even managed to restore my old config (a few issues here and there that weren't hard to solve). With nearly everything up and running I had a look at my PPtP connection and it just seemed unable to connect.

At first I realized ppp-mod-pptp wasn't enough, and I was missing kmod-nf-nathelper-extra, which I promptly installed. Retried to connect, but to no avail.

I then conjectured that maybe some (figurative) gremlins may exist in my OpenWRT-originated config, so I reset to factory defaults for good measure. Once again I reinstalled all the necessary packages and tried connecting, but there was no indication of it working.

I should note that within this time frame the logs were not showing any information related to pptp! No errors, no indication of starting the connection, I even tried editing /etc/ppp/options{..pptp}, to enable debug flags but they were not outputting anything.

I've tried to search this for the last few hours and I have been unable to narrow it down to a case similar to mine. It's especially hard considering I have no logs to go by.

Any and all help would be appreciated.
Thanks!

Hello again,

Update: Today is tomorrow and after a series of re-flashes a few things have changed.

Firstly, I flashed back to OpenWRT and to my surprise I got similar behaviour! I took this as the overarching issue not being a firmware specific problem, and flashed back to LEDE.

I then promptly tried to check if the PPtP server was actually working, something I, embarrassingly, had taken for granted (because it was working up to the point of me upgrading) and it was responding very intermittently.

So in terms of the PPtP connection it would appear as if the server is to blame, but It's all very odd because, if that were the case, I would at least expect to see some error output. But up to the point before flashing 17.01.4 for the last time I was seeing no output whatsoever from pppd.

It was for some reason failing silently, but is now logging errors as expected. I don't have the first clue about why this is happening. Does anyone have any insight as to why this "silent failure" was happening?

You might download and run Wireshark and see if it gives you any clues...

https://www.wireshark.org/