PPPOEoa support

Hi Guys,
I noticed my fiber optic service provider using PPPOEoa protocol.
Is Lede support this ?
If so, how can I do it?

TGIF :slight_smile:

Yes. Select PPPoATM.

Thank you for reply.
My provider installed Huawei HG253s router.
On the router connection type PPOE selected. But it is not. I noticed connection type is pppoeoa while I trying to cover password.
We have huge debate in Turkey. Operator does not allow use another router.

If you saying I can use pppoa modulation. So I need vpi /vci values. Do you think can I cover with wireshark or someting else.
This values not exposed on operator provided router.


See this article...


Yes, I tried both 8/35 and 0/35 vpi/vci values. Also I tried it for VC-Mux and LLC encapsulation.
I didn't work, unfortunately.
May be pppoeoa has liitle subtle protocol differences with pppoa and thats why they does not want to share information.
Although they says you can use your own router with only if you have adsl connection, with fiber connection we do not allow it.
It is nonsense.

It is almost guaranteed that they will not actually use ATM on their "fiber"product, which is either EPON/GPON, or maybe just VDSL with the "fiber" moniker only denoting that the DSLAM/MSAN is connected to its upstream by a fiber... (looking at turkcell's website makes me believe its real fiber though.)
Now, in theory one could use ATM even with a VDSL or a fiber system (the ITU standards certainly allow for that), but since Telcos are trying hard to get rid of the old and aging ATM equipment, I would be really really amazed if your ISP would offer its fiber product using ATM encapsulation.
But with a bit of luck, assuming your ISP supplied router does allow you to get onto the internet, you should be able to empirically deduce whether ATM is used on your link or not, following the instructions on https://github.com/moeller0/ATM_overhead_detector. Most likely though this is a waste of time, since ATM/AAL5 is highly unlikely on your fiber link.

But I guess your ISP either uses PPPoE or DHCP, but they might be only allowing certain MAC addresses, so you might need to clone the ISP routers WAN mac if you want to use your own router/modem. BTW which router model do you want to use instead of the ISP's HG253s?

Best Regards

Yes operator is Turkcell and they are using gpon technology, as far as I know.
Fiber optic cabled directly in my room.
I wiresharked wan interface I found out they using custom PPPoE Host Uniq Tags

I have Lede enabled Linksys WRT1200AC. As expected, my router does not have this option.
I don't know it is possible to add this host uniq tag or not ?
Futhermore, operator router destination mac address appeared directly.



Have a look at https://wiki.openwrt.org/doc/uci/network it should well be possible to specify the host uinq value in /etc/config/network (search for host_uniq, I do believe this is not available in the GUI though).

That should also be fixable, also in /etc/config/network with the macaddr option also apparently not exposed in the GUI.

Best Regards

Thank you for your help.
I managed to add PPPoE Host_Unig tag and Operators Huawei router source mac address for my connection.
Only thing, I could't find how to add Destination Mac address area.
That mac address is specified by router.

Well, I believe this is not something you need to configure manually. How do packet captures with the new "faked" mac address and the ISP-expected host-uniq string looking?

Best Regards

Wan port directly connected to my laptop.Wireshark enabled then router powered on.
Both router logged like that.

As you can see Huawei router sending additional different type of info "Active Discovery Terminate(PADT)" with specific mac address.

Although Linksys sending only "Active Directory Initiation (PADI)" messages.
And both source mac address and pppoed tag - host_unig is same.


I have been seeing something similar with my ISP, (the additional PADTs from an ISP configured Huawei mode,/router), but the big issue for me was simply that my ISP required VLAN7 for the PPPoE connection to fully establish. But my quick research on turkcell did not reveal any required VLAN for internet access (even though I can not speak or read Turkish, so my failure to find something might simply be caused by my lack of ability). I guess this is where I have to admit that I am out of ideas, and hope you still can solve your issue somehow...

I think Wireshark will show if VLANs are running on the cable. That is almost universal on a FTTH system.

The network (ONT) should answer a PADI with a PADO packet, which is how the router discovers the ONT's MAC address.

There is a way to skip the discovery process entirely and force a specific connection (including the peer's MAC), described in the man pages for pppoe. There are some interesting probing operations that can be done by manually running pppoe from the command line.