PPPoE won't connect to ISP after reboot

Hello, I have a problem where the PPPoE interface will not connect to the ISP after rebooting the router. After booting up, it starts infinitely reloading the pppd plugin and fails with the error "Timeout waiting for PADO packets."

This is my first OpenWRT router, and everything is done on a clean instance.

Manually navigating to devices through LuCI and reconfiguring the WAN fixes the issue, and the router then connects to the internet. I've seen many topics with similar issues, but there are no apparent solutions.

My setup is an ASUS RT-AX53U running OpenWrt 23.05.4. The router’s WAN port is connected to the ISP modem, which converts the optical cable to Ethernet.

What I've tried so far:

  • Changing the MAC address of the WAN device
  • Setting keepalive to 5 5 on the WAN interface
  • Changing the default DNS servers
  • Setting up a local startup script to run ubus call network restart, which partially worked but introduced wireless issues
  • Factory resetting and setting up the PPPoE interface again
/etc/config/network
config interface 'loopback'                                                     
        option device 'lo'                                                      
        option proto 'static'                                                   
        option ipaddr '127.0.0.1'                                               
        option netmask '255.0.0.0'                                              
                                                                                
config globals 'globals'                                                        
        option ula_prefix 'fd8d:****:****::/48'                                 
        option packet_steering '1'                                              
                                                                                
config device                                                                   
        option name 'br-lan'                                                    
        option type 'bridge'                                                    
        list ports 'lan1'                                                       
        list ports 'lan2'                                                       
        list ports 'lan3'                                                       
                                                                                
config interface 'lan'                                                          
        option device 'br-lan'                                                  
        option proto 'static'                                                   
        option ipaddr '192.168.1.1'                                             
        option netmask '255.255.255.0'                                          
        option ip6assign '60'                                                   
                                                                                
config interface 'wan'                                                          
        option device 'wan'                                                     
        option proto 'pppoe'                                                    
        option username ‘******’                                                  
        option password ‘******’                                              
        option ipv6 'auto'                                                      
        option keepalive '5 5'                                                  
        option pppd_options 'debug'                                             
                                                                                
config device                                                                   
        option name 'wan'
Relevant part of the log
Mon Sep 16 22:09:29 2024 daemon.notice netifd: Network device 'wan' link is up
Mon Sep 16 22:09:29 2024 daemon.notice netifd: Interface 'wan' has link connectivity
Mon Sep 16 22:09:29 2024 daemon.notice netifd: Interface 'wan' is setting up now
Mon Sep 16 22:09:29 2024 kern.info kernel: [   46.750772] mtk_soc_eth 1e100000.ethernet wan: Link is Up - 100Mbps/Full - flow control off
Mon Sep 16 22:09:29 2024 daemon.info pppd[3520]: Plugin pppoe.so loaded.
Mon Sep 16 22:09:29 2024 daemon.info pppd[3520]: PPPoE plugin from pppd 2.4.9
Mon Sep 16 22:09:29 2024 daemon.notice pppd[3520]: pppd 2.4.9 started by root, uid 0
Mon Sep 16 22:09:29 2024 daemon.debug pppd[3520]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Mon Sep 16 22:09:29 2024 daemon.debug pppd[3520]:  dst ff:ff:ff:ff:ff:ff  src **:**:**:**:**:**
Mon Sep 16 22:09:29 2024 daemon.debug pppd[3520]:  [service-name] [host-uniq  c0 0d 00 00]
Mon Sep 16 22:09:30 2024 kern.info kernel: [   47.790817] mtk_soc_eth 1e100000.ethernet wan: Link is Down
Mon Sep 16 22:09:30 2024 daemon.notice netifd: Network device 'wan' link is down
Mon Sep 16 22:09:30 2024 daemon.notice netifd: Interface 'wan' has link connectivity loss
Mon Sep 16 22:09:30 2024 daemon.err pppd[3520]: select (waitForPADO): Interrupted system call
Mon Sep 16 22:09:30 2024 daemon.warn pppd[3520]: Timeout waiting for PADO packets
Mon Sep 16 22:09:30 2024 daemon.err pppd[3520]: Unable to complete PPPoE Discovery
Mon Sep 16 22:09:30 2024 daemon.info pppd[3520]: Exit.
Mon Sep 16 22:09:30 2024 daemon.notice netifd: Interface 'wan' is now down
Mon Sep 16 22:09:31 2024 daemon.warn odhcpd[1577]: No default route present, overriding ra_lifetime!
Mon Sep 16 22:09:32 2024 daemon.notice netifd: Network device 'wan' link is up
Mon Sep 16 22:09:32 2024 daemon.notice netifd: Interface 'wan' has link connectivity
Mon Sep 16 22:09:32 2024 daemon.notice netifd: Interface 'wan' is setting up now
Mon Sep 16 22:09:32 2024 kern.info kernel: [   49.870764] mtk_soc_eth 1e100000.ethernet wan: Link is Up - 100Mbps/Full - flow control off
Mon Sep 16 22:09:32 2024 daemon.info pppd[3717]: Plugin pppoe.so loaded.
Mon Sep 16 22:09:32 2024 daemon.info pppd[3717]: PPPoE plugin from pppd 2.4.9
Mon Sep 16 22:09:32 2024 daemon.notice pppd[3717]: pppd 2.4.9 started by root, uid 0
Mon Sep 16 22:09:32 2024 daemon.debug pppd[3717]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Mon Sep 16 22:09:32 2024 daemon.debug pppd[3717]:  dst ff:ff:ff:ff:ff:ff  src **:**:**:**:**:**
Mon Sep 16 22:09:32 2024 daemon.debug pppd[3717]:  [service-name] [host-uniq  85 0e 00 00]
Mon Sep 16 22:09:33 2024 kern.info kernel: [   50.910698] mtk_soc_eth 1e100000.ethernet wan: Link is Down
Mon Sep 16 22:09:33 2024 daemon.notice netifd: Network device 'wan' link is down
Mon Sep 16 22:09:33 2024 daemon.notice netifd: Interface 'wan' has link connectivity loss
Mon Sep 16 22:09:33 2024 daemon.err pppd[3717]: select (waitForPADO): Interrupted system call
Mon Sep 16 22:09:33 2024 daemon.warn pppd[3717]: Timeout waiting for PADO packets
Mon Sep 16 22:09:33 2024 daemon.err pppd[3717]: Unable to complete PPPoE Discovery
Mon Sep 16 22:09:33 2024 daemon.info pppd[3717]: Exit.
Mon Sep 16 22:09:33 2024 daemon.notice netifd: Interface 'wan' is now down

Open to any suggestions and can provide any necessary info

P.S: I'm not good with network stuff, so some terminology might be off

PADO is pppoe config offer, likely you need to select vlan.

I've researched VLAN and figured that the VLAN ID should be provided by the ISP. Is that correct? If so, I'll try to contact them, but I haven't seen anything mentioning VLAN in their setup guides.

I was also wondering if I could figure out which VLAN ID should be used from the established connection, which happens after reconfiguring the WAN device.

UPD: I've got a reply from ISP technical support, they're saying that they don't use VLAN on their lines. I guess that's out of the question then?

Who is the ISP?

I've been seeing a WAN PPPoE issue that was recently fixed in snapshot in Mediatek routers like the MT6000, MT2500, MT3000 and MR90x but I've not seen it on the MT7621 devices.

1 Like

ISP is a Russian middle-of-nowhere business; I don't think it'll provide any insight, to be honest. ISP actually offers two ways to connect: L2TP tunnel and PPPoE.

I've been trying to set up L2TP for some time, but I was getting basically the same results, having to restart devices/interfaces by hand to get an internet connection. L2TP always worked fine on previous routers, but OpenWRT was giving me trouble. Having to install packages and change too many settings to get it working created too many potential breaking points, so I decided against that route.

Then I noticed that there was a way to connect through PPPoE (but the guide did not offer any setup instructions for routers, contrary to L2TP), so I decided to try it out.

I might look into snapshots, but I'm trying to find the path of least resistance at the moment.

Well, it is up to you to guess among 4095 possible vlan values. Probably you can extract one from original CPE.