PPPoE with Vigor 167 - How to set up OpenWRT?

Hello,

Up front: As a networking-beginner, I don't really know what information is needed. Please let me know what information I should add, I will append it asap.

The Goal
I want to connect my Linksys WRT1900AC (OpenWRT 21.02.3) router to DSL-internet via a Vigor 167 modem.

What did I try?
I connected the Vigor 167 to the DSL socket in the wall and connected Port 1 of the modem to the routers 'Internet' port.

I edited the existing WAN interface via LuCi to use the PPPoE-protocol, typed in username (1und1/ab0000-000@online.de) and password given by my ISP and applied.

Result
The WAN interface gives me the error 'Connection attempt failed'

How could you help me?
As I am very new to this whole topic of networking, I would appreciate a link to a noob-friendly guide to set up a system as described above or a hint how I can learn to do that. Although I am very sure that I am not the first one with this set up, I couldn't find good resources on the topic. I guess I don't even know what to ask for.

I have to add that I am also using a PiHole to filter DNS-requests (setup in the LAN-interface with 6,192.168.10.132) and a NordVPN-connection set up after this guide. Maybe that complicates things, I don't reall know. Everything works when I use my Fritzbox 7430 before the Linksys router. But I want to get rid of the Fritzbox, the outside-IP from my ISP should be directly at the WAN interface. Currently, the Interfaces look like this:


The WAN interface gets the IP from the Fritzbox.

Any help is very much appreciated!

First of all you should log in to the Vigor directly from a computer. Do a few things there:

  1. check that the Modem is set to bridge mode, as said by Yorper.
  2. change the Vigors Subnet to something different from your openwrt subnets. Use IP:10.0.0.1 Subnet: 255.255.255.0/24 under Lan >> General Setup, for instance. You should do this to acces your modem later from within the lan.
  3. Check that the Vigor is set to tag the Connection, under Internet Access >> General Setup. The Vigor should already be set to Vlan 7 by default, which is the right vlan for 1und1.

In openwrt append a capital "H" in front of your pppoe-username: "H1und1/ab0000-000@online.de". Openwrt should now connect via pppoe.

As last step you should add an Interface to acces your Modems interface from your lan: https://openwrt.org/docs/guide-user/network/wan/access.modem.through.nat, using 10.0.0.2 as the openwrt's ip on the modem interface.

1 Like

That worked! Thank you very much!

As some points were a bit different at my end, I will write down how it worked for me, in case someone has the same system:

  1. To log into the Vigor 167 I had to set my IP4-options on my PC manually to 192.168.1.77, Netmask 255.255.255.0, DNS 1.1.1.1
    After connecting Port 1 of the Vigor to the ethernet socket of my PC I could open the interface by visiting http://192.168.1.1 in my Browser (admin/admin as username/password)
    The DSL-Cable was also connected to the Vigor so it had time to automatically find and set the options for my connection (VDSL2 in my case)

  2. Check Modem is set to bridge mode:
    I really had no choice, there was only one option available:

  3. Change Subnet: as Sailor said. I found the option under Configuration -> LAN -> Edit
    After changing and saving those options, I had to repeat Step 1 to log in again (with the new IP address instead)

  4. As Sailor wrote, the Vigor already set Vlan 7 by default, nothing to do here (for me at least, with 1&1 (ISP) and VDSL2)

  5. As Sailor wrote, configuring the WAN interface on OpenWRT came down to changing the protocol to PPPoE and entering the PAP/CHAP username and password given by my ISP. With an H in front of the username! How are you even supposed to know that...

  6. I had also to change the DNS on the WAN interface on advanced settings:


    The DNS settings advertised by peer didn't work, after changing them to 1.1.1.1 I could browse normally again.

I didn't set up the Modem access yet, just enjoying that everything works now.

Thanks again!

Openwrt won't use the advertised DNS servers, unless you tick checkbox right above the custom DNS serves input line.

If I check the box, both custom DNS fields disappear:


vs.

Doesn't that mean I have to uncheck it for my custom DNS to work, or did I misunderstand you?

When you tick the checkbox. Openwrt will use the dns advertised by your isp. However you can still make dnsmasq use costum dns servers as upstream servers in lucis dns/dhcp tab.
I was just saying, that the missing dns servers, where actually part of your configuration.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.