Pppoe unable to log in to vodafone

i have a vodafone connection and i wish to replace my existing router with a openwrt router. i bought a NETGEAR D7800 which supports the vdsl protocol that vodafone uses.
i know the connection supports other types of router becasue i had a cisco in it that worked fine
i already have the required login details but for some reason this router fails to connect to vodafone. the inteface on the gui is red and reports user error. the log freports bringing up the pppoe interface with no errors, but there is no connection.

i am new to openwrt so i'm on a steep learning curve

here's the existing configuration

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.0.0.254'

config interface 'wan'
	option device 'eth0.101'
	option proto 'pppoe'
	option username 'myusername'
	option password 'mypassword'
	option ipv6 'auto'


network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdd3:91f1:e7b1::/48'

network.@device[0]=device
network.@device[0].name='br-lan'
network.@device[0].type='bridge'
network.@device[0].ports='eth1.1'


network.lan=interface
network.lan.device='br-lan'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ipaddr='10.0.0.254'

network.wan=interface
network.wan.device='eth0.101'
network.wan.proto='pppoe'
network.wan.username='myUsername'
network.wan.password='MyPassword'
network.wan.ipv6='auto'

network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='1 2 3 4 6t'
network.@switch_vlan[0].vid='1'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='101'
network.@switch_vlan[1].ports='0t 5t'
network.@switch_vlan[1].vid='101'
network.@switch_vlan[1].description='vodafone broadband'

network.@device[1]=device
network.@device[1].name='eth0.101'
network.@device[1].type='8021q'
network.@device[1].ifname='eth0'
network.@device[1].vid='101'
network.@device[1].macaddr='8C:3B:AD:B6:C2:D3'
network.@device[1].txqueuelen='1000'
network.@device[1].mtu6='1492'
network.@device[1].mtu='1500'
network.@device[2]=device
network.@device[2].name='eth0'
network.@device[2].macaddr='8C:3B:AD:B6:C2:D3'
network.@device[2].txqueuelen='1000'
network.@device[2].mtu6='1492'
network.@device[2].mtu='1500'
-
firewall
-
firewall.@defaults[0]=defaults
firewall.@defaults[0].syn_flood='1'
firewall.@defaults[0].input='ACCEPT'
firewall.@defaults[0].output='ACCEPT'
firewall.@defaults[0].forward='REJECT'
firewall.@zone[0]=zone
firewall.@zone[0].name='lan'
firewall.@zone[0].input='ACCEPT'
firewall.@zone[0].output='ACCEPT'
firewall.@zone[0].forward='ACCEPT'
firewall.@zone[0].network='lan'
firewall.@zone[1]=zone
firewall.@zone[1].name='wan'
firewall.@zone[1].input='REJECT'
firewall.@zone[1].output='ACCEPT'
firewall.@zone[1].forward='REJECT'
firewall.@zone[1].masq='1'
firewall.@zone[1].mtu_fix='1'
firewall.@zone[1].network='wan'
firewall.@forwarding[0]=forwarding
firewall.@forwarding[0].src='lan'
firewall.@forwarding[0].dest='wan'
firewall.@rule[0]=rule
firewall.@rule[0].name='Allow-DHCP-Renew'
firewall.@rule[0].src='wan'
firewall.@rule[0].proto='udp'
firewall.@rule[0].dest_port='68'
firewall.@rule[0].target='ACCEPT'
firewall.@rule[0].family='ipv4'
firewall.@rule[1]=rule
firewall.@rule[1].name='Allow-Ping'
firewall.@rule[1].src='wan'
firewall.@rule[1].proto='icmp'
firewall.@rule[1].icmp_type='echo-request'
firewall.@rule[1].family='ipv4'
firewall.@rule[1].target='ACCEPT'
firewall.@rule[2]=rule
firewall.@rule[2].name='Allow-IGMP'
firewall.@rule[2].src='wan'
firewall.@rule[2].proto='igmp'
firewall.@rule[2].family='ipv4'
firewall.@rule[2].target='ACCEPT'
firewall.@rule[3]=rule
firewall.@rule[3].name='Allow-DHCPv6'
firewall.@rule[3].src='wan'
firewall.@rule[3].proto='udp'
firewall.@rule[3].dest_port='546'
firewall.@rule[3].family='ipv6'
firewall.@rule[3].target='ACCEPT'
firewall.@rule[4]=rule
firewall.@rule[4].name='Allow-MLD'
firewall.@rule[4].src='wan'
firewall.@rule[4].proto='icmp'
firewall.@rule[4].src_ip='fe80::/10'
firewall.@rule[4].icmp_type='130/0' '131/0' '132/0' '143/0'
firewall.@rule[4].family='ipv6'
firewall.@rule[4].target='ACCEPT'
firewall.@rule[5]=rule
firewall.@rule[5].name='Allow-ICMPv6-Input'
firewall.@rule[5].src='wan'
firewall.@rule[5].proto='icmp'
firewall.@rule[5].icmp_type='echo-request' 'echo-reply' 'destination-unreachable' 'packet-too-big' 'time-exceeded' 'bad-header' 'unknown-header-type' 'router-solicitation' 'neighbour-solicitation' 'router-advertisement' 'neighbour-advertisement'
firewall.@rule[5].limit='1000/sec'
firewall.@rule[5].family='ipv6'
firewall.@rule[5].target='ACCEPT'
firewall.@rule[6]=rule
firewall.@rule[6].name='Allow-ICMPv6-Forward'
firewall.@rule[6].src='wan'
firewall.@rule[6].dest='*'
firewall.@rule[6].proto='icmp'
firewall.@rule[6].icmp_type='echo-request' 'echo-reply' 'destination-unreachable' 'packet-too-big' 'time-exceeded' 'bad-header' 'unknown-header-type'
firewall.@rule[6].limit='1000/sec'
firewall.@rule[6].family='ipv6'
firewall.@rule[6].target='ACCEPT'
firewall.@rule[7]=rule
firewall.@rule[7].name='Allow-IPSec-ESP'
firewall.@rule[7].src='wan'
firewall.@rule[7].dest='lan'
firewall.@rule[7].proto='esp'
firewall.@rule[7].target='ACCEPT'
firewall.@rule[8]=rule
firewall.@rule[8].name='Allow-ISAKMP'
firewall.@rule[8].src='wan'
firewall.@rule[8].dest='lan'
firewall.@rule[8].dest_port='500'
firewall.@rule[8].proto='udp'
firewall.@rule[8].target='ACCEPT'
-
interfaces
-
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 8c:3b:ad:b6:c2:d3 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::8e3b:adff:feb6:c2d3/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 8c:3b:ad:b6:c2:d2 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::8e3b:adff:feb6:c2d2/64 scope link 
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 8c:3b:ad:b6:c2:d2 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.254/24 brd 10.0.0.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fdd3:91f1:e7b1::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::8e3b:adff:feb6:c2d2/64 scope link 
       valid_lft forever preferred_lft forever
8: eth1.1@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 8c:3b:ad:b6:c2:d2 brd ff:ff:ff:ff:ff:ff
10: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 8c:3b:ad:b6:c2:d5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::8e3b:adff:feb6:c2d5/64 scope link 
       valid_lft forever preferred_lft forever
11: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 8c:3b:ad:b6:c2:d4 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::8e3b:adff:feb6:c2d4/64 scope link 
       valid_lft forever preferred_lft forever
74: eth0.101@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 8c:3b:ad:b6:c2:d3 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::8e3b:adff:feb6:c2d3/64 scope link 
       valid_lft forever preferred_lft forever
-
route
-
10.0.0.0/24 dev br-lan scope link  src 10.0.0.254

read the last part, taken from https://openwrt.org/toh/netgear/d7800

image

1 Like

oh right. thank you. is that likely to change in the future or should i look for another router?
thank you for your replay. i am now not pulling my hair out.

I doubt it, there's probably no support for the *DSL part of the device in the Linux kernel.

You want something Lantiq based..

If you're in UK, the BT HH5A is probably the easiest one to find, even preflashed (try eBay), but there's some kind of issue with the recent openwrt version, making it boot loop.

EDIT: seems it's fixed in 22.03.4.

1 Like

much appreciated for the comback. yes i'm looking at those now.
can use the netgreas as a wifi extender.
i don't have a problem with flashing opnwrt to the new router. i did it with this one. saying that, the routers you mentioned are cheap enough, even the flashed ones. thank you for your responses.

depends on what you mean by extender, but yes.

flashing the BT HH5A is however slightly more complicated :wink:

it does look slightly more complicated :slight_smile: however i may get an already flashed one and a unflashed one si i can go throguh the experience.
i have some eletrical competence.