PPPOE take too much long time to reconnect Internet after the ISP IP changed

Hi, I'm a newbie for openwrt.
I have installed the openwrt on an ESXi vm. The everything works well, except one:
PPPOE take too much long time to reconnect internet after the ISP IP changed.
My ISP change the public IP every 3 days.
When the IP changed, I lost the connection to my router (openwrt), it needs to take 8 or more hours to reconnect to the internet. I added a script to detect the IP change, then restart the openwrt's network. But it can't help. It seems openwrt can't detect the IP change.

How can I do? Is it configuration error?

Expect your help! Thanks!

-Anndy.

In PPPoE the ISP will terminate the session, so that the routers will initiate a new connection and get a new IP.
It is not clear to me if your OpenWrt gets the new IP and doesn't route packets to the internet or stays without IP.
The output of uci export network would be helpful.

@trendy, Thanks for your help!
Where can I find the output of uci export network?

You have to log into your device using SSH, then execute that command.

@eduperez, Many thanks for your help! The following is the output:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd65:64e0:7f7d::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0 eth1'
        option proto 'static'
        option ipaddr '192.168.2.254'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth2'
        option proto 'pppoe'
        option keepalive '0'
        option ipv6 '0'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'
        option auto '0'
        option reqaddress 'none'
        option reqprefix 'auto'

Try changing the "keepalive" parameter to "5 5".

3 Likes

Also erase from your previous post the username and password.

1 Like

@eduperez and @trendy,
Many thanks again!
I changed it.

The config keepalive '5 5' works.
Today, My ISP changed the IP, and my openwrt re-connected soon.
Many thanks to @eduperez!

2 Likes

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).

grafik

2 Likes

Hi @trendy,
I marked the solution, but I can't edit (couldn't pencil icon) the topic.

That's fine!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.