PPPoE suddenly failing -- what to do?


I have an ADSL over ATM connection (bonded DSL) from ISP to a ZyXel modem/router provided by my ISP. For over a year I have successfully set the ZyXel to bridge mode and used the stock firmware of a Netgear R7800. However, I have terrible bufferbloat through my ISP and the QoS on the Netgear wasn't cutting it.

About a week or two ago, I switched to OpenWrt (the latest stable @hnyman build) and turned on cake and piece of cake SQM management. My Ds and Fs on dslreports.com speedtest became As. I would (every day or two) lose PPPoE connection, but it would work fine again after restarting WAN interface. Otherwise OpenWrt worked great.

However, this past Friday, my connection shut down and has been unusable all weekend. I assumed it was a hardware line problem, but my ISP reported that it was fine. To test, I disconnected the Netgear and turned on the routing function of the ZyXel and the connection is perfect (insofar as it is, decent throughput results but Fs on bufferbloat). As soon as I put the ZyXel in Bridge mode and reconnect my Netgear with OpenWrt, it refuses the PPPoE connection as soon as the UI shows a MAC address for the WAN interface (PEER_DEAD, sometimes NEGOTIATION_FAILED after restarting interface, mostly simply connection failed).

Given that this router-modem worked for a year stock, and worked for a couple weeks with openWrt, what should I do to diagnose from here? Do some ISPs not like something my openWrt QoS (or whatever) is doing and maybe blocked it?

Thanks all for the help. I very much want to keep OpenWrt with Piece of Cake... when it worked, it made my DSL connection fantastic!

The ISPs probably doesn't like MAC address changes of your router.

1 Like

Check the logs. Sounds like authentication is being rejected, sometimes the ISP sends a message saying why.

1 Like

my provider is very picky about mac address.. at the end i had to clone the provider device mac to my router to avoid problems.. worth a try if you find no other solution..


1 Like

Thank you all!

So two things:

  1. While my ISP isn't cutting me off due to MAC address, I do think it's behaving differently. I am going to spoof my modem MAC onto my WAN port of the router using OpenWrt and see if I see any difference. Thanks for the suggestion!

  2. Much of my woes were in fact a line problem that the modem obscured. My ISP sent a tech out and he fixed two shorts in the copper between my property and their building. OpenWrt's connection has been flawlessly stable since then. I'm not sure why the modem has an easier time remaining connected to the ISP when such problems exist on the line, but OpenWrt's PPPoE handling was dumping me constantly (and is not doing that at all now that the line is fixed). I did add the keepalive option to /etc/config/network under the pppoe configuration, so maybe that will help in the future.

I'm always interested in before/after dslreports and rrul test result? happy u fixed it

1 Like


Thanks! OpenWrt with cake has made it possible for me to present during meetings since I'm working full time from home these days. Before, I would sometimes see bufferbloat over 3000ms on the upload side running stock Netgear R7800 firmware (or using the ISP-supplied modem/router, which was even worse). Trying to share my screen and hold a reasonable conversation at the same time was... a challenge. Now, it's fantastic.

Before I installed OpenWrt:

Using OpenWrt with cake--piece of cake:

cool. go help a neighbor or school district on fixing it too?