PPPoE setup on ipv6 or ipv4?


If I have configred pppoe for IPv4 for my provider, do I need to have WAN6 running. It's setup by default as DHCPv6 client, so it looks as pictured. Is that correct?


wan6 is bound to to wan, with DHCPv6 client. It seems u had configured it as DHCPv6, but haven't bound it to wan.

This is my setting on /etc/config/network

config interface 'want'
	option ifname 'eth3'
	option proto 'pppoe'
	option username 'cliente@cliente'
	option password 'cliente'
	option peerdns '1'
	option dns ','
	option ipv6 '1'
	option delegate '0'
	option metric '10'
config interface 'want6'
	option ifname '@want'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option peerdns '0'
	option metric '20'
	option reqprefix '56'

If you didn't change anything, it is correct. However does your provider allocate IPv6?

I've been trying to figure that out actually. I'm not sure if they do.

Why not call them and ask?

1 Like

I switched WAN to PPPoE and it looks like this:

(public IPs redacted)
It seems that WAN_6 can't be added to the zone and has no settings in it.

wan_6 is being generated automatically out of wan.

If u're receiving public IPv4 and IPv6 PD, then it's working properly.

You can add it for sure.

Also note that DHCP server is enabled on WAN (not WAN6), but I think for PPPoE, DHCP server should be on lan. It seems there is no way to disable DHCP server in LuCI once enabled, and it will require editing the /etc/config/dhcp file or some UCI command to disable.

By default it is not.

For any protocol, there is no need to enable dhcp server on wan.

What you probably did was to switch to static protocol, enable dhcp server, then rolled back to pppoe. Undo the steps and disable the dhcp server on wan. Or uci set dhcp.wan.ignore='1'; uci commit dhcp; service dnsmasq restart

Yes it doesn't make sense... but that's what I got with fresh install of 21.02rc3? (I factory reset thrice until I stopped messing things up...) Oh well, maybe I was clueless.

1 Like