PPPoE question about MTU

I am currently using my DIR-860l to connect to my ISP through a 500/500 Mb/s PPPoE connection. Because of the 8 byte overhead of the PPPoE protocol, the MTU of this connection is just 1492. Of course I could set the MTU of all my devices to 1492 as well, but this is not very practical when guests are coming over.

In order for devices with a MTU of 1500 to work properly as well, MSS clamping can be used to circumvent the problem. By default, MSS clamping is ticked in the firewall settings at the WAN zone. My question: Should MSS clamping also be ticked in the LAN zone? And why (not)?

LAN to LAN traffic will never see PPPoE encapsulation ad hence there is no need to reduce the MTU from the default 1500; heck you might even want to use jumbo frames in your LAN with MTU >> 1500. All packets traversing your WAN interface will be clamped to MTU 1492, making sure nobody sends larger packets nicely avoiding fragmentation...

Best Regards

or maybe your provider supports baby jumbo frames (MTU 1508) ? have you tried ?

I haven't tried that yet. I would have to set the MTU of the WAN ethernet port to 1508, and the MTU of the PPPoE connection to 1500, right? Where can I edit the MTU value of specific interfaces?

advanced settings


1 Like

Thank you very much for the very informative link. Unfortunately, setting the MTU on eth0 to 1508 does not do anything. Running ifconfig still shows a MTU of 1500 on eth0. Does anyone happen to know how I can fix this? Are jumbo-frames not supported on the switch in the DIR-860l?

Edit: I found this link: http://lists.infradead.org/pipermail/lede-dev/2016-August/002445.html
Is this still the case in LEDE? Or is there a way to set MTUs larger than 1500 on the switch?

Edit2: I tried to set the MTU manually through ifconfig, but I am getting the following error:

root@LEDE:~# ifconfig eth0 mtu 1508
ifconfig: SIOCSIFMTU: Invalid argument

Setting the MTU to values <= 1500 results in no error and works properly.