[SOLVED]PPPoE problems with Deutsche Telekom

Hi everyone,

I installed openWRT 18.06.02 on an Arcadyan VGV7510KW22 (o2 Box 6431) and so far, everything seems to be fine. The only, but major problem is, I cannot establish a PPPoE connection.

I have VDSL2 with 100Mbit and to enable vectoring I installed additional xdsl-modem firmware. The DSL connection itself does not cause any trouble, as can be seen here:

Line State: UP [0x0]
Line Mode: G.993.5 (VDSL2 with down- and upstream vectoring)
Line Uptime: 18m 26s
Annex: B
Profile: 17a
Data Rate: 97.623 Mb/s / 39.534 Mb/s
Max. Attainable Data Rate (ATTNDR): 127.621 Mb/s / 43.847 Mb/s
Latency: 0.13 ms / 0.0 ms
Line Attenuation (LATN): 5.7 dB / 4.1 dB
Signal Attenuation (SATN): 5.7 dB / 4.1 dB
Noise Margin (SNR): 12.7 dB / 10.1 dB
Aggregate Transmit Power(ACTATP): -3.9 dB / 13.4 dB
Forward Error Correction Seconds (FECS): 0 / 5
Errored seconds (ES): 0 / 154
Severely Errored Seconds (SES): 0 / 28
Loss of Signal Seconds (LOSS): 3 / 0
Unavailable Seconds (UAS): 221 / 221
Header Error Code Errors (HEC): 0 / 0
Non Pre-emtive CRC errors (CRC_P): 0 / 0
Pre-emtive CRC errors (CRCP_P): 0 / 0
ATU-C System Vendor ID: Broadcom 177.238
Power Management Mode: L0 - Synchronized

But I repeatedly get the following error in the log:

daemon.notice netifd: Interface 'wan' is now down
daemon.notice netifd: Interface 'wan' is disabled
daemon.notice netifd: Interface 'wan' is enabled
daemon.notice netifd: Interface 'wan' is setting up now
daemon.err insmod: module is already loaded - slhc
daemon.err insmod: module is already loaded - ppp_generic
daemon.err insmod: module is already loaded - pppox
daemon.err insmod: module is already loaded - pppoe
daemon.info pppd[5907]: Plugin rp-pppoe.so loaded.
daemon.info pppd[5907]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
daemon.notice pppd[5907]: pppd 2.4.7 started by root, uid 0
daemon.warn pppd[5907]: Timeout waiting for PADO packets
daemon.err pppd[5907]: Unable to complete PPPoE Discovery
daemon.info pppd[5907]: Exit.

I also tagged the WAN port with VLAN ID 7, and changed the WAN device from dsl0 to "eth0.7" but to no avail.

I also stumbled over these two post, but they didn't help, sadly.

Is it possible to tag dsl0 with an VLAN ID? Like dsl0.7

Here is my network configuration:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8f:5830:917c::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'
	option ds_snr_offset '0'
	option firmware '/lib/firmware/dsl_vr9_firmware_xdsl-05.07.06.0A.00.07_05.07.01.0C.00.02.bin'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0.1'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 '1'
	option ifname 'eth0.7'
	option username 'xxx#0001@t-online.de'
	option password 'xxx'

config device 'wan_dev'
	option name 'dsl0'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 5 6t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '7'
	option ports '0t 6t'

Any help is appreciated.

Best Toni

I believe you need to set this to dsl0.7....

2 Likes

I believe so...

So I am still on 17 so I have a ptm instead of a dsl device:

config dsl 'dsl'
        option xfer_mode 'ptm'
        option annex 'b'
        option tone 'bv'
        option line_mode 'vdsl'
        option firmware '/etc/config/dsl_vr9_firmware_xdsl-05.08.01.05.00.07_05.08.00.09.00.01.bin'

config device 'ptm_dev'
        option ifname 'ptm0'
        option name 'ptm0.7'
        option type '8021q'
        option mtu '1500'
        option mac 'FF:EE:DD:CC:BB:AA'
        option vid '7'

config interface 'wan'
        option proto 'pppoe'
        option ipv6 '1'
        option pppd_options 'debug'
        option _orig_ifname 'ptm0.101'
        option _orig_bridge 'false'
        option ifname 'ptm0.7'
        option username 'USERID@t-online.de'
        option password '$SECRETPASSWORD'

I had to do exactly this set

config interface 'wan'
	option proto 'pppoe'
	option ipv6 '1'
	option username 'xxxx@t-online.de'
	option password 'xxx'
	option ifname 'dsl0.7'

Just had to change it from dsl0 to dsl0.7

Is your firmware from a fritzbox? Could you send me the bin file? It seems a little newer than mine.

So this works now? You might want to change the title of the thread to:
[SOLVED] PPPoE problems with Deutsche Telekom

This firmware came from a netgear dm200, if I recall correctly. I am on an A0-Anschluss in the Nahbereich and hence my line is not yet using vectoring, so I can not tell you how well that firmware (that should support vectoring, according to https://xdarklight.github.io/lantiq-xdsl-firmware-info/ where I got it from, but since it is not tested I wanted to mention that)

I just found the firmware.

The problem I have now is that the router keeps resetting when the throughput is too high. Have to investigate this. But I guess I should mark this topic as solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.