PPPoE not working on Archer ax23v1

Hi. Sorry if this has been resolved before -- I tried searching the forum but didn't find anything that discussed my particular problem.

So, I bought an Archer ax23v1 recently and flashed OpenWrt. I configured my wan for pppoe, but I don't get an IP address on that interface. This is my /etc/config/network file:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxxx:xxxx:xxxx::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username 'xxxx@sbb.ne.jp'
        option password 'xxx'
        option ipv6 '0'
        option pppd_options 'debug'

My provider is SoftBank (Japan). I'm using an FTTH connection.

This is my /etc/openwrt_release file:

DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='23.05.5'
DISTRIB_REVISION='r24106-10cc5fcd00'
DISTRIB_TARGET='ramips/mt7621'
DISTRIB_ARCH='mipsel_24kc'
DISTRIB_DESCRIPTION='OpenWrt 23.05.5 r24106-10cc5fcd00'
DISTRIB_TAINTS=''

I have ppp, kmod-pppoe, and ppp-mod-pppoe packages installed.

To begin with, I'd at least like to see what's happening with ppp. I tried logread | grep ppp but saw only 2 lines none of which said anything about any error happening with ppp. I also tried ps | grep pppd but didn't see the ppp daemon running. I'm not familiar with either ppp or pppd, so for now I'm stuck. Is there a way to at least confirm that the ppp daemon is being run when I do ifup wan or /etc/init.d/network restart, and why it isn't getting an IP?

Thank you for your help in advance. :slight_smile:

run logread -f via ssh, restart the wan interface, post the output.

1 Like

Most FTTH providers use VLANs, can you check the configuration from another device? Also, some ISPs restrict the connections to devices with a specific MAC, you might need to clone the MAC address from the provided router.

And what is logged when you restart WAN (logread -e pppd)

1 Like

Thank you for your replies.

This is the log when I do ifup wan:

root@OpenWrt:~# logread -f
Tue Jan  7 11:14:05 2025 daemon.notice netifd: Interface 'wan' is disabled
Tue Jan  7 11:14:05 2025 kern.info kernel: [  633.627558] mtk_soc_eth 1e100000.ethernet wan: PHY [mdio-bus:04] driver [Generic PHY] (irq=POLL)
Tue Jan  7 11:14:05 2025 kern.info kernel: [  633.636414] mtk_soc_eth 1e100000.ethernet wan: configuring for phy/rgmii link mode
Tue Jan  7 11:14:05 2025 daemon.notice netifd: Interface 'wan' is enabled

The ax23 was able to get a connection with stock firmware, so I doubt it's a problem with MAC. To be sure, I tried the MAC address of my previous router which works, but it still didn't get a connection. I didn't find any VLAN setting in my previous router either.

So far my concern is that there's no sign of pppd running when configuring this interface.

then try to clone the WAN MAC of the old router onto the WAN of the AX23.

Sorry, that's what I tried. I mean, I copied the WAN MAC of the old router onto the WAN of the AX23, but didn't change the other MAC addresses.