PPPoE not working in Xiaomi AX3600

I'm trying to get a PPPoE connection in my AX3600 from my ISP (FTTH Movistar), using their AIO router in bridge mode, so its giving an untagged PPPoE connection.

I've the parameters as requested by my ISP:

  • PPPoE
  • user/pass: adslppp@telefonicanetpa / adslppp
  • MTU/MRU: 1492
  • Tried manual DNS aswell

It does not require any vlan tagging.

Somehow, after hours of trying, it got connected a few times to PPPoE and got internet, but not anything I can reproduce easily, most time I just get PADO timeout.

Here is my net config, which I donĀ“t know if it's right, since im pretty new to dsa and this thing doesn't have ethX interfaces:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdaf:xxxx:xxxx::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	option bridge_empty '1'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan.21'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'pppoe'
	option username 'adslppp@telefonicanetpa'
	option password 'adslppp'
	option disable '0'
	option ipv6 '0'
	option mtu '1492'
	option mru '1492'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config bridge-vlan
	option device 'br-lan'
	option vlan '21'
	list ports 'lan1:u*'

config device
	option type 'bridge'
	option name 'br-lan2'
	list ports 'lan2'
	option bridge_empty '1'
	option mtu '1500'
	option txqueuelen '1000'
	option ipv6 '0'
	option macaddr '88:C3:97:XX:XX:XX'

config bridge-vlan
	option device 'br-lan2'
	option vlan '31'
	list ports 'lan2:u*'

config interface 'Camaras'
	option proto 'static'
	option device 'br-lan2.31'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

config device
	option type 'bridge'
	option name 'br-lan3'
	list ports 'lan3'
	option bridge_empty '1'
	option mtu '1500'
	option txqueuelen '1000'
	option ipv6 '0'
	option macaddr '88:C3:97:XX:XX:XX'

config bridge-vlan
	option device 'br-lan3'
	option vlan '41'
	list ports 'lan3:u*'

config interface 'Guest'
	option proto 'static'
	option device 'br-lan3.41'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'

config device
	option name 'wan'
	option ipv6 '0'
	option macaddr 'CC:ED:DC:XX:XX:XX'

The PPPoE works well with ISP router in normal mode, so tried to place ISP router mac address on the wan interface aswell, but no luck.
Also tried to connect to PPPoE with OS X (don't know how to change MTU here), and with a WR840N on stock firmware, but also no luck.
I'm pretty sure the problem is on my side and not ISP side, I'm stupidly missing something.
Started with default config in both routers, just setting ISP router to bridge mode and changing wan port to pppoe on AX3600 and adding login credentials and MTU/MRU, but didn't work.

Any advice?

Solved it. After an ISP reset and unplugging 1 LAN port which was used on ISP router PPPoE instantly worked.