PPPoE don't set up

PPPoE don't establishes a connecting. Eth1 is for WAN, Eth0 is for switch. TP-Link tl-wr741nd OpenWRT 18.06.2

I've test all: physical connection, performance of port in router, correcting input; it's all ok. There are strange, that WAN led is blink. Also he has print UNKNOWN_ERROR and rarely USER_REQUEST

Watch the logs.

Dmesg print this every second :face_with_raised_eyebrow: :

SQUASHFS error: Unable to read fragment cache entry [1f8dba]
SQUASHFS error: Unable to read page, block 1f8dba, size 1ca98
eth1: link down
IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
eth1: link up (100Mbps/Full duplex)
IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready

I need to check FS…

"dmesg" shows kernel messages, you should use "logread" for this type of issue.

Squashfs error suggests the rootfs in flash is corrupted. Try re-flashing (sysupgrade with the same image you have, do not save settings, and re-configure from scratch). On a 4/32 router you can only make a few basic settings because of lack of space in the flash.

1 Like

with me solved reinstalling openwrt

The problem has solved by reinstalling OpenWRT

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.