PPPoE Connection "Unknown error: User Request" // Deutsche Telekom VDSL

Hello there,

after I changed my router to a Netgear R6220 and flashed OpenWRT, I am not able to establish a connection for my VDSL from Deutsche Telekom via PPPoE. In front of my router, a Zyxel VDSL modem is in Bridge Mode.

Here is my configuration:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxx'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'xxx'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'xxx'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '3 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '7'

config interface 'PPPoE'
	option proto 'pppoe'
	option ipv6 'auto'
	option ifname 'eth0.7'
	option password 'xxx'
	option type 'bridge'
	option username 'Anschlusskennung+Zugangsnummer+Mitbenutzernummer@t-online.de'

PPPoE username is as described from my ISP.

I appricate you help.

Thank you.
Lasko

Check the settings in the wiki.

I added two missing lines. Now it looks like this:

config interface 'PPPoE'
	option proto 'pppoe'
	option ipv6 'auto'
	option ifname 'eth0.7'
	option password 'xxx'
	option type 'bridge'
	option username 'xxx+xxx+0001@t-online.de'
	option _orig_ifname 'ptm0'
	option _orig_bridge 'false'

Still, connection apptemp failed.
Also the username provided in the wiki is wrong and does not match a direct contract with the ISP, as 1&1 is not directly Deutsche Telekom. '@online.de’ is also wrong as it needs to be '@t-online.de'.

Any Idea, why it still fails?

I'm not familiar with Deutsche Telekcom VDSL, but is your Zyxel bridge modem perhaps already configured to use VLAN ID 7 ?

Have you confirmed the Zyxel is working in bridge mode with another known router?

If Zyxel is configured to use VLAN ID 7, then your Netgear, perhaps should use default settings for WAN interface

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '2'     #  this may be the default for R6220

config interface 'PPPoE'
	option proto 'pppoe'
	option ipv6 'auto'
	option ifname 'eth0.2'      #  I think this may be the default for R6220
	option password 'xxx'
	option type 'bridge'
	option username 'Anschlusskennung+Zugangsnummer+Mitbenutzernummer@t-online.de'

If I'm wrong, someone will correct me.

ps. I've changed all the online to read t-online.de in the wiki page.

These 2 lines are for Lantiq based devices with modem, yours has mediatek without modem.
Which line are you using exactly from the examples mentioned in the wiki?
The username/password you are going to use should match what your provider has assigned to you, regardless of what is in the wiki.

Which one, and which firmware is it running (in particular, is it running a "Telekom Firmware")? I might have an idea what's wrong.

It is a Zyxel VMG1312-B30A running Firmware 1.00(AAEB.7) (not from Telekom, bought this modem seperate).

By the way, I hope I have enough replays left^^

Modem is running with VDSL in Bridge mode, no VLAN tag assigned with the modem. Also I deactivated the firewall there, as this is recommended from the Zyxel forum.

As an information: I got a connection via my old Fritzbox 7362SL. You can find the working configuration here: No Connection to Internet via Notebook and Amazon FireTV
Please ignore the question from this topic.

Alright, so you are running exactly the same setup as I am: an R6220 and a VMG1312.

This is a "Telekom firmware", the most recent one at the time of this post.

As far as I can tell, this is Zyxel's latest firmware, but "pre-configured" for Deutsche Telekom customers with one interesting twist: They know their customers will need their PPPoE connection tagged with VLAN ID 7, so It adds VLAN ID 7 to the incoming PPPoE connection on LAN port 4.

Their documentation describes it like this:

Which means you have the following options:

  • tag the router's WAN/PPPoE with VLAN ID 7 and connect it to to port 1, 2 or 3 on the Zyxel (I never tried this)
  • leave the router's WAN/PPPoE untagged and connect it to port 4 of the Zyxel

If you tag your WAN with VLAN ID 7 on your OpenWrt router, and connect it to the Zyxel's LAN port 4, it will not work. I believe this is because the same mechanism that adds the VLAN tag on port 4 also removes it on the way back to the router, which then will ignore the untagged traffic (I am absolutely not sure about that, though.)

I believe by sheer luck, you had your tagged WAN/PPPoE connected to port 4 of the Zyxel, which is the only option that will not work.

My recommendation would be:

  • for good measure, factory-reset the modem ... the Zyxel already comes configured as bridge modem, nothing else needs to be done there (at least for it to work initially)
  • connect the R6220's WAN port to the Zyxel's LAN port 4, this way you don't have to care about VLAN tagging at all
  • on the R6220, you only need the following configuration (which is the default WAN configuration, the same as if you reset your OpenWrt to defaults and set WAN to PPPoE):
config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option password '(your PPPoE username)'
        option ipv6 'auto'
        option username '(your PPPoE password)'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr '(you should, by default, have a MAC address here)'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

(Edited, for posterity, with a more general explanation if someone else ever runs into this very specific issue.)

3 Likes

Does this YT video describing how to enable bridge mode and setting VLAN ID 7 on a Zyxel router help ?
https://youtu.be/ZLSIDUSd38U

It works! I reset the modem and don't touch it.
But now I have the same problem as in the following topic: No Connection to Internet via Notebook and Amazon FireTV

When I try to go to e.g. https://duckduckgo.com/ or reddit.com I get an "Connection error". Is there something else I need to configure? Google, Youtube and some othere websites works fine. But most fail.

Edit: I forgot to enable DHCP on my notebook and had a static assigned adress. Now everything works. Thank you very much :slight_smile:

You can do that. I seem to remember it improves the speed a tiny bit (which only matters if you are hitting 100 mbit anyway). But it doesn't make a big difference.

Note that, even if seems tempting, you must not disable QOS on the Zyxel if you are using the "automatic" VLAN tagging on LAN port 4. The Zyxel actually tags the VLAN via a QOS rule (see Network Setting > QOS > Class Setup in the Zyxel's admin interface.)

As for your other problem, sorry, I never encountered that and can't be of assistance there.

It could be an MTU issue if you can access some websites and not others?

For PPPoE, the maximum value is typically 1492 (openwrt default may be 1500). What happens if you lower it to a ridiculously low value such as 1400 on the R6220 ?

1 Like

Thank you for our help.
The error with the websites was, that I still had a static IP address assigned on my notebook. After changing to DHCP everything works as expected.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.