PPPoE connection problem

I have a TP-Link TD-W8970B router with a builtin dsl modem and installed successfully latest LEDE.
I'm trying to get a pppoe connection but failed.

Using tcpdump I can see PADI requests on the outgoing interface (ptm0) but the DSLAM does not answer with PADO.

logread shows:

Thu Jan 19 04:24:16 2017 daemon.err pppd[21499]: Unable to complete PPPoE Discovery

If I use my other DSL modem (no LEDE installed), I don't have any issues.

I have a annex B dsl connection that will be switched to annex J in the near future.

Has anyone similar issues or any idea what can be done?

This smells like a deutsche telekom line to me. Assuming you are already connected to a new-style BNG instead of an old-style BRAS you might need to use VLAN tag 7 on the WAN interface carrying the PPPoE traffic.

Okay, DTAG is switching all lines including their old ADLS ones to VLAN7 as this is part of the requirement to work with the new BNGs, so there truely is change happening. Most DTAG supplied modems, with sufficiently modern firmware, will automatically do the right thing, at least if used as router. I have a speedport w723vA that will work nicely as a VLAN7 using router, but will not work in bridge-mode, as it will neither add the VLAN tag nor accept tagged packets on its LAN interfaces. The phenotype I see when I try to use the 723 in bridgetype is exactlt that I get sync/showtime on the VDSL connection, but I PADO timeouts, which is to be expected as the PADI requests naver make it to the PPPoE server end... Oh, and if you do not have a vdsl line you need atm, ptm (while introduced as an annex to ADSL) is to my knowledge excusively used on VDSL lines (at least for DTAG that seems still to be true). The best debugging tool would be a tcpdump from the modem...

Best Regards

i also try to use a W8970B on DTAG.
but i dont know hot to add the vlan 7 to my config.
can someone help me?

this is my current config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'some ipv6'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config dsl 'dsl'
        option annex 'j'
        option xfer_mode 'atm'
        option line_mode 'adsl'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'ptm0'
        option proto 'pppoe'
        option ipv6 'auto'
        option username 'my usernumber'
        option password 'my pw'

config device 'wan_dev'
        option name 'ptm0'
        option macaddr 'my mac'

config interface 'wan6'
        option ifname 'pppoe-wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 4 5 6t'

Did you have any success? I am having a similar issue on Eir (formally Eircom) in Ireland.

    Wed Jul 12 00:05:50 2017 daemon.notice netifd: Interface 'wan' is setting up now
Wed Jul 12 00:05:50 2017 kern.info kernel: [  470.999733] mv643xx_eth_port mv643xx_eth_port.1 eth1: link up, 1000 Mb/s, full duplex, flow control disabled
Wed Jul 12 00:05:50 2017 daemon.info pppd[6210]: Plugin rp-pppoe.so loaded.
Wed Jul 12 00:05:50 2017 daemon.info pppd[6210]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Wed Jul 12 00:05:50 2017 daemon.notice pppd[6210]: pppd 2.4.7 started by root, uid 0
Wed Jul 12 00:05:50 2017 daemon.debug pppd[6210]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 00:05:50 2017 daemon.debug pppd[6210]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 00:05:50 2017 daemon.debug pppd[6210]:  [service-name]
Wed Jul 12 00:05:55 2017 daemon.debug pppd[6210]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 00:05:55 2017 daemon.debug pppd[6210]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 00:05:55 2017 daemon.debug pppd[6210]:  [service-name]
Wed Jul 12 00:06:00 2017 daemon.debug pppd[6210]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 00:06:00 2017 daemon.debug pppd[6210]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 00:06:00 2017 daemon.debug pppd[6210]:  [service-name]
Wed Jul 12 00:06:05 2017 daemon.warn pppd[6210]: Timeout waiting for PADO packets
Wed Jul 12 00:06:05 2017 daemon.err pppd[6210]: Unable to complete PPPoE Discovery
Wed Jul 12 00:06:05 2017 daemon.info pppd[6210]: Exit.
Wed Jul 12 00:06:05 2017 daemon.notice netifd: Interface 'wan' is now down
Wed Jul 12 00:06:05 2017 daemon.notice netifd: Interface 'wan' is disabled
Wed Jul 12 00:06:05 2017 daemon.notice netifd: Interface 'wan' is enabled
Wed Jul 12 00:06:05 2017 daemon.notice netifd: Interface 'wan' is setting up now
Wed Jul 12 00:06:05 2017 kern.info kernel: [  486.179716] mv643xx_eth_port mv643xx_eth_port.1 eth1: link up, 1000 Mb/s, full duplex, flow control disabled
Wed Jul 12 00:06:05 2017 daemon.info pppd[6325]: Plugin rp-pppoe.so loaded.
Wed Jul 12 00:06:05 2017 daemon.info pppd[6325]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Wed Jul 12 00:06:05 2017 daemon.notice pppd[6325]: pppd 2.4.7 started by root, uid 0
Wed Jul 12 00:06:05 2017 daemon.debug pppd[6325]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 00:06:05 2017 daemon.debug pppd[6325]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 00:06:05 2017 daemon.debug pppd[6325]:  [service-name]
Wed Jul 12 00:06:10 2017 daemon.debug pppd[6325]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 00:06:10 2017 daemon.debug pppd[6325]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 00:06:10 2017 daemon.debug pppd[6325]:  [service-name]
Wed Jul 12 00:06:15 2017 daemon.debug pppd[6325]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 00:06:15 2017 daemon.debug pppd[6325]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 00:06:15 2017 daemon.debug pppd[6325]:  [service-name]
Wed Jul 12 00:06:20 2017 daemon.warn pppd[6325]: Timeout waiting for PADO packets
Wed Jul 12 00:06:20 2017 daemon.err pppd[6325]: Unable to complete PPPoE Discovery
Wed Jul 12 00:06:20 2017 daemon.info pppd[6325]: Exit.
Wed Jul 12 00:06:20 2017 daemon.notice netifd: Interface 'wan' is now down
Wed Jul 12 00:06:20 2017 daemon.notice netifd: Interface 'wan' is disabled
Wed Jul 12 00:06:20 2017 daemon.notice netifd: Interface 'wan' is enabled
Wed Jul 12 00:06:20 2017 daemon.notice netifd: Interface 'wan' is setting up now
Wed Jul 12 00:06:20 2017 kern.info kernel: [  501.359782] mv643xx_eth_port mv643xx_eth_port.1 eth1: link up, 1000 Mb/s, full duplex, flow control disabled
Wed Jul 12 00:06:20 2017 daemon.info pppd[6440]: Plugin rp-pppoe.so loaded.
Wed Jul 12 00:06:20 2017 daemon.info pppd[6440]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Wed Jul 12 00:06:20 2017 daemon.notice pppd[6440]: pppd 2.4.7 started by root, uid 0
Wed Jul 12 00:06:20 2017 daemon.debug pppd[6440]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
Wed Jul 12 00:06:20 2017 daemon.debug pppd[6440]:  dst ff:ff:ff:ff:ff:ff  src 58:6d:8f:f5:cb:7d
Wed Jul 12 00:06:20 2017 daemon.debug pppd[6440]:  [service-name]

Yes, I have it running and works great. better than the device from my isp.
the error at the beginning was not on my side. My isp did not connect the dsl line properly.
someone from there service had to redo the dsl line, i mean not at my home.
I added the vlan like this. but i didn't even test it without the vlan. maybe it will still work...
well here is a screenshot where do do the vlan.

image of wan interace imgur.com/H96SV6f

some parts of my network config:

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 'auto'
	option username '______@t-online.de'
	option password '______'
	option _orig_ifname 'ptm0'
	option _orig_bridge 'false'
	option ifname 'ptm0.7'

config device 'wan_dev'
	option name 'ptm0'
	option macaddr '__________'

config interface 'wan6'
	option ifname 'pppoe-wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

and the dsl status:

Status: UP
Line State: showtime_tc_sync [0x801]
Line Mode: G.993.2 (VDSL2)
Annex: B
Profile: 17a
Data Rate: 25.088 Mb/s / 5.056 Mb/s
Max. Attainable Data Rate (ATTNDR): 41.185 Mb/s / 5.445 Mb/s
Latency: 8.0 ms / 7.0 ms
Line Attenuation (LATN): 25.9 dB / 38 dB
Signal Attenuation (SATN): 23.4 dB / 26 dB
Noise Margin (SNR): 13.5 dB / 5.8 dB
Aggregate Transmit Power(ACTATP): 3.7 dB / 14.6 dB
Forward Error Correction Seconds (FECS): 113602363 / 142895
Errored seconds (ES): 112 / 165
Severely Errored Seconds (SES): 0 / 52
Loss of Signal Seconds (LOSS): 0 / 52
Unavailable Seconds (UAS): 25 / 25
Header Error Code Errors (HEC): 0 / 0
Non Pre-emtive CRC errors (CRC_P): 452 / 0
Pre-emtive CRC errors (CRCP_P): 0 / 0
Line Uptime: 6d 7h 22m 36s
ATU-C System Vendor ID: Broadcom 164.97
Power Management Mode: L0 - Synchronized

Slightly off-topic:

If you are still on the old BRAS platform it should work without vlan7 on the new BNG platform it will not work without vlan7. Officially you also need to use vlan7 for vdsl access to the BRAS platform, but in reality it works without (the reason might be that at BRAS ADSL links do not use a vlan at all, so either an intermediary component will create a vlan tunnel to the BRAS transparently, or the BRAS will also tolerate flows without vlan7). But with the BNG platform there is ATM no single report of successful connections without VLAN7.
Figuring out the platform used can be done if you log the PPPoE connection establishment, if the AC-NAME contains a J on the fourth position (after a 3 letter location abbreviation) then you are connected to a BNG (the J signifies juniper)...

Best Regards