Pppoe config doesn't work after updating to 19.07.3

Hi

I was previously on a snapshot using this config without problems:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb3:2b09:61b9::/48'
	option packet_steering '1'

config interface 'lan'
	option type 'bridge'
	option ifname 'lan1 lan2 lan3'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	list dns '192.168.1.133'
	option ip6assign '64'

config interface 'wan'
	option proto 'pppoe'
	option username 'theISPuser'
	option password 'theISPpass'
	option ifname 'wan.20'
	option peerdns '0'
	list dns '192.168.1.133'
	option ipv6 'auto'

In 19.07.3 "wan.20" is no longer available.

Trying to reproduce with Luci my previous set-up, I get an "Unknown error (User request)"

Can you, please, help me with it?

Thanks!

PS. I'm on a Xiaomi r3p

Snapshots use DSA for switch configuration while 19.07 relies on the old swconfig framework. You need to redo your network configuration from scratch and do the VID 20 tagging on wan using swconfig switch vlans.

2 Likes

Thanks! Good to know. I'm back to the snapshot for now. I'll try it again as soon I have some time available

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.