PPPoE can't authenticate via a bridged router

My ISP provided PPC ONT is setup in bridge mode as described here

From my ISP router configuration it seems a VLAN ID of 256 is required which i have set but i still get connection attempt failed even though i have cloned the mac address of my isp ont aswell


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4a:6c4a:59be::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option macaddr '64:fb:92:33:a4:94'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option gateway '192.168.1.2'
        option broadcast '192.168.1.255'

config interface 'wan'
        option proto 'pppoe'
        option device 'br-lan.256'
        option username 'Kx0'
        option password 'x'
        option ipv6 'auto'
        option keepalive '10 1'

config device
        option name 'eth0.256'
        option type '8021q'
        option ifname 'eth0'
        option vid '256'
        option macaddr '64:xxxx'

have you tried using eth.256 as wan interface?

Yes i have, same thing.

I did notice my service name being populated after resetting my isp router, i can't edit the service name aswell hence i can't copy it. Could that be the issue? the service name is in astreiks.

Got my ISP on call, they remotely enabled bridging on my ONU, then I tried setting up my openwrt router and they waited for a connection to show up to bind the allowed Mac address to my new router, it never did and we gave up, so the ISP doesn't even get a connection request.