PPPoA/E WAN over bridge modem to get public IP

Hi, I am using an ASUS RT-AC1200 router with a Netgear DM200 modem.

Model - ASUS RT-AC1200 V2
Architecture - MediaTek MT7628AN ver:1 eco:2
Target Platform - ramips/mt76x8
Firmware Version OpenWrt 22.03.0 r19685 / LuCI openwrt-22.03 branch git-22.245.77528

The DHCP WAN did not work for me as I would want my OpenWRT router to be able to retrieve the public IP of the internet, also some site I VPN to is not working under this setup, "error 806 at least one device not configured to allow GRE protocol packets".

My ISP is Plusnet in UK, it recommands using PPPoA while on ADSL, I have followed the setup instruction, /etc/config/network looks like this

`config dsl 'dsl'
        option annex 'a'
        option tone 'a'
        option xfer_mode 'atm'
        option line_mode 'adsl'

config device
        option name 'dsl0'
        option macaddr 'XX:XX:XX:XX:XX:50'

config interface 'wan'
        option proto 'pppoa'
        option username 'usrname@plusdsl.net'
        option password '*******
        option vpi '0'
        option vci '38'
        option encaps 'vc'
        option ipv6 'auto'


however I am getting error in logread as follow

daemon.err insmod: module is already loaded - slhc
daemon.err insmod: module is already loaded - ppp_generic
daemon.err insmod: module is already loaded - pppox
daemon.err insmod: module is already loaded - pppoatm
daemon.info pppd[14310]: Plugin pppoatm.so loaded.
daemon.notice pppd[14310]: pppd 2.4.9 started by root, uid 0
daemon.err pppd[14310]: connect(0.38): No such device
daemon.info pppd[14310]: Exit.
daemon.err netifd[5051]: proto_shell_handler(231): run teardown for interface 'wan'
daemon.notice netifd: Interface 'wan' is now down
daemon.err netifd[5051]: interface_queue_event(122): Queue hotplug handler for interface 'wan', event 'ifup-failed'
daemon.err netifd[5051]: call_hotplug(98): Call hotplug handler for interface 'wan', event 'ifup-failed' (none)
daemon.notice netifd: Interface 'wan' is setting up now
daemon.err netifd[5051]: proto_shell_handler(231): run setup for interface 'wan'
daemon.err netifd[5051]: task_complete(107): Complete hotplug handler for interface 'wan'

The error daemon.err pppd[14310]: connect(0.38): No such device seems to come from the option vci 38 setup, I tried change it to vci 1 error will change to connect(0.1): No such device. The VCI 38 is also in the ISP recommendation.

I have also read the ISP configuration and tried something, but none worked.

I am not fulling understanding the situation, is the pppd complaining about a missing dsl device? I am starting to think it has nothing to do with the configuration but be because my router does not have this capability. I tried to "configure" a eth0.38 device, I also tried some PPPoe setup, but every other methods I tried failed.

Does any know how I should achieve what I want? or do I need other hardware?

Back in some other country its much simpler, I simply used DHCP WAN and the ISP modem / device gave my router the public IP.

It's a bit unclear which device you're trying to configure, the DM200 or the RT-AC1200.

PPPoA can only be configured on the device containing the xDSL modem (so the DM200), while the more common PPPoE can be configured on either device. If your ISP also supports PPPoE, it usually makes more sense to use that - putting the DM200 into bridge mode and terminating the PPPoE session and your WAN IP on the RT-AC1200.

While not exactly the same device, the bthub5a has very similar hardware and a very good documentation and guide (including recipes for common UK ISPs), so reading https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266 first might help you with your endeavour.

My goal is for my router to obtain the public IP, while my ISP plusnet does not seem to support PPPoE.

So is there any way if my DM200 performs the PPPoA, my router can obtain the public IP? Or I simply have to use a different router that also has the xDSL modem, while the current Asus RT-AC1200 seems does not?

just to clarify, I had only been configuring the Asus RT-AC1200 router, the netgear DM200 I simply left it in bridge mode without any configuration.