PPP Interface causes other bridge to not come up

Hi all, I'm having a weird issue involving using a cell modem. Essentially, I have two three bridge interfaces in total. Without the added third "cell" interface, the br-vlan interface comes up fine. Once I add in the PPP related interfaces, it no longer works.

Here's my network file:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd37:8453:da23::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.5.7'

config device
        option name 'br-vlan'
        option type 'bridge'
        list ports 'eth0.3'

config interface 'vlan'
        option device 'br-vlan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.6.7'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr '0c:cf:89:6f:9b:f8'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0.2'

config interface 'cell'
        option type 'bridge'
        option ifname 'ppp0'
        option proto 'static'
        option ipaddr 'my modem address'
        option netmask '255.255.255.0'
        option gateway 'ptp address'
        option dns 'ptp address'

config interface 'wan2'
        option ifname 'ppp0'
        option proto 'ppp'
        option device '/dev/ttyUSB2'
        option speed '921600'
        option file '/etc/ppp/peers/att-QBG95'
        option connect '/usr/sbin/chat -v -f /etc/ppp/peers/att-QBG95-chat'
        option ipv6 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'wwan'
        option proto 'dhcp'

Once I do "service network restart", ipconfig shows this:

br-lan    Link encap:Ethernet  HWaddr 40:D6:3C:5D:1F:D6
          inet addr:192.168.5.7  Bcast:192.168.5.255  Mask:255.255.255.0
          inet6 addr: fe80::42d6:3cff:fe5d:1fd6/64 Scope:Link
          inet6 addr: fd37:8453:da23::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1192 (1.1 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:931 errors:0 dropped:0 overruns:0 frame:0
          TX packets:931 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:75329 (73.5 KiB)  TX bytes:75329 (73.5 KiB)

ppp-wan2  Link encap:Point-to-Point Protocol
          inet addr:*redacted*  P-t-P:*redacted*  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:11 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:518 (518.0 B)  TX bytes:834 (834.0 B)

wlan0     Link encap:Ethernet  HWaddr 40:D6:3C:5D:1F:D6
          inet6 addr: fe80::42d6:3cff:fe5d:1fd6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1952 (1.9 KiB)

any thoughts about what could be wrong? any help would be appreciated

what is this address? Is it a public IP? or is it an RFC1918 address (for example, one starting with 192.168.x.x)? If uncertain, post the first two octets (in bold aaa.bbb.ccc.ddd)

yes it is a public IP, first two octets are 100.68

Actually, that's not public -- it's CG-NAT. But, it's non-overlapping, so that is not going to cause you any issues.

Try removing the option type 'bridge' line from this.

That doesn't seem to have worked, still no br-vlan interface. Do I even need the 'cell' interface at all?

It looks like you don’t have eth0.3 defined in the switch config. What physical/logical port(s) does it connect to? And should it be tagged or untagged?

I believe I want all the traffic to remain untagged. My only need so far was keep the traffic from forwarding between either br-lan to br-vlan or vice versa. Firewall zones seemed to work well enough for that. And there are no physical ports on my machine, its just OpenWRT on a board connected to my cell modem board.

So where did all of this come from?

This implies that there is a switch chip with a 4+1 port configuration (5 ports total).

If there is no ethernet on your system, you don't need eth0.3 on the bridge. And for that matter, VLANs aren't technically relevant when there is no ethernet (it is a semantic thing, VLANs apply to ethernet only; what you have is multiple subnet configuration).

What is your device?

ubus call system board
{
        "kernel": "5.10.161",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7688 ver:1 eco:2",
        "model": "Hi-Link HLK-7688A",
        "board_name": "hilink,hlk-7688a",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.3",
                "revision": "r20028-43d71ad93e",
                "target": "ramips/mt76x8",
                "description": "OpenWrt 22.03.3 r20028-43d71ad93e"
        }
}

Yes, I agree I'm just using multiple subnets to control traffic. I also agree, it is 4+1. That came from when I built the openwrt image from the buildroot, I think

So is everything just using wifi (beyond the cellular modems)?

Yes. I'm dynamically changing which wireless networks I'm hosting on both subnets. Based on user input, I may need to connect to another gateway as a client. Or host multiple networks, in addition to maintaining a data connection from pppd.

ok... so if no ethernet is involved, remove eth0.3 from the bridge. Then restart your device and see what happens -- if the bridge still doesn't come up, let's see your logs.

You should consider upgrading to 22.03.5 -- you can simply download the standard release build and start over from scratch (i.e. do not keep settings) which might get rid of the switch stuff that doesn't belong.

Removing that line from the bridge did seem to work! Thank you so much.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.