PPP connects to Cell Network but Internet doesn't work

I'm having a few issues using PPP to setup an internet connection. Essentially I have a modem connected via serial, and PPP successfully configures the modem using my chatscript. However once the connection is up, the internet does not work. Here's the general cycle from logread:

Fri Jul 21 17:29:46 2023 daemon.notice pppd[6669]: pppd 2.4.9 started by root, uid 0
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: timeout set to 3 seconds
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: send (AT^M)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: expect (OK)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: AT^M^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: OK
Fri Jul 21 17:29:47 2023 local2.info chat[6692]:  -- got it
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: send (AT+CGDCONT=1,"IPV4V6","super"^M)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: expect (OK)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: ^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: AT+CGDCONT=1,"IPV4V6","super"^M^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: OK
Fri Jul 21 17:29:47 2023 local2.info chat[6692]:  -- got it
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: send (AT+CFUN=1^M)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: expect (OK)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: ^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: AT+CFUN=1^M^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: OK
Fri Jul 21 17:29:47 2023 local2.info chat[6692]:  -- got it
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: send (AT+QCSQ;+CEREG?;+COPS?;+CGDCONT?^M)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: expect (OK)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: ^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: AT+QCSQ;+CEREG?;+COPS?;+CGDCONT?^M^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: +QCSQ: "eMTC",-62,-97,56,-20^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: ^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: +CEREG: 0,5^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: ^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: +COPS: 0,0,"Verizon Wireless",8^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: ^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: +CGDCONT: 1,"IPV4V6","super","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: +CGDCONT: 2,"IPV4V6","ota.super","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: ^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: OK
Fri Jul 21 17:29:47 2023 local2.info chat[6692]:  -- got it
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: send (ATD*99#^M)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: expect (CONNECT)
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: ^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: ATD*99#^M^M
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: CONNECT
Fri Jul 21 17:29:47 2023 local2.info chat[6692]:  -- got it
Fri Jul 21 17:29:47 2023 local2.info chat[6692]: send (150000000^M)
Fri Jul 21 17:29:48 2023 daemon.debug pppd[6669]: Script /usr/sbin/chat -v -f /etc/ppp/peers/att-QBG95-chat finished (pid 6692), status = 0x0
Fri Jul 21 17:29:48 2023 daemon.info pppd[6669]: Serial connection established.
Fri Jul 21 17:29:48 2023 daemon.debug pppd[6669]: using channel 44
Fri Jul 21 17:29:48 2023 kern.info kernel: [ 3419.304661] ppp-wan2: renamed from ppp0
Fri Jul 21 17:29:48 2023 daemon.info pppd[6669]: Renamed interface ppp0 to ppp-wan2
Fri Jul 21 17:29:48 2023 daemon.info pppd[6669]: Using interface ppp-wan2
Fri Jul 21 17:29:48 2023 daemon.notice pppd[6669]: Connect: ppp-wan2 <--> /dev/ttyUSB2
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x4fcf299f>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [LCP ConfReq id=0x56 <asyncmap 0x0> <auth chap MD5> <magic 0xb8937e0a> <pcomp> <accomp>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: No auth is possible
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [LCP ConfRej id=0x56 <auth chap MD5> <pcomp> <accomp>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x4fcf299f>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [LCP ConfReq id=0x57 <asyncmap 0x0> <magic 0xb8937e0a>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [LCP ConfAck id=0x57 <asyncmap 0x0> <magic 0xb8937e0a>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [LCP EchoReq id=0x0 magic=0x4fcf299f]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::d8fe:10a0:2a23:70a5>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [LCP DiscReq id=0x58 magic=0xb8937e0a]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [LCP EchoRep id=0x0 magic=0xb8937e0a 4f cf 29 9f]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [IPCP ConfReq id=0xa0]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [IPCP ConfNak id=0xa0 <addr 0.0.0.0>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [IPCP ConfRej id=0x1 <compress VJ 0f 01>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [IPCP ConfReq id=0xa1]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [IPCP ConfAck id=0xa1]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [IPCP ConfNak id=0x2 <addr 100.77.*.*> <ms-dns1 8.8.8.8> <ms-dns2 8.8.4.4>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: sent [IPCP ConfReq id=0x3 <addr 100.77.*.*> <ms-dns1 8.8.8.8> <ms-dns2 8.8.4.4>]
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: rcvd [IPCP ConfAck id=0x3 <addr 100.77.*.*> <ms-dns1 8.8.8.8> <ms-dns2 8.8.4.4>]
Fri Jul 21 17:29:49 2023 daemon.warn pppd[6669]: Could not determine remote IP address: defaulting to 10.64.64.64
Fri Jul 21 17:29:49 2023 daemon.notice pppd[6669]: local  IP address 100.77.*.*
Fri Jul 21 17:29:49 2023 daemon.notice pppd[6669]: remote IP address 10.64.64.64
Fri Jul 21 17:29:49 2023 daemon.notice pppd[6669]: primary   DNS address 8.8.8.8
Fri Jul 21 17:29:49 2023 daemon.notice pppd[6669]: secondary DNS address 8.8.4.4
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: Script /lib/netifd/ppp-up started (pid 6757)
Fri Jul 21 17:29:49 2023 daemon.notice netifd: Network device 'ppp-wan2' link is up
Fri Jul 21 17:29:49 2023 daemon.notice netifd: Interface 'wan2' is now up
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: using nameserver 8.8.8.8#53
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: using nameserver 8.8.4.4#53
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri Jul 21 17:29:49 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri Jul 21 17:29:49 2023 daemon.debug pppd[6669]: Script /lib/netifd/ppp-up finished (pid 6757), status = 0x1
Fri Jul 21 17:29:50 2023 user.notice firewall: Reloading firewall due to ifup of wan2 (ppp-wan2)
Fri Jul 21 17:29:52 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::*ipv6 address*>]
Fri Jul 21 17:29:55 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::*ipv6 address*>]
Fri Jul 21 17:29:58 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::*ipv6 address*>]
Fri Jul 21 17:30:01 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::*ipv6 address*>]
Fri Jul 21 17:30:04 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::*ipv6 address*>]
Fri Jul 21 17:30:07 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::*ipv6 address*>]
Fri Jul 21 17:30:10 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::*ipv6 address*>]
Fri Jul 21 17:30:13 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::*ipv6 address*>]
Fri Jul 21 17:30:16 2023 daemon.debug pppd[6669]: sent [IPV6CP ConfReq id=0x1 <addr fe80::*ipv6 address*>]
Fri Jul 21 17:30:19 2023 daemon.warn pppd[6669]: IPV6CP: timeout sending Config-Request
Fri Jul 21 17:31:56 2023 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Fri Jul 21 17:31:57 2023 daemon.info pppd[6669]: Terminating on signal 15
Fri Jul 21 17:31:57 2023 daemon.info pppd[6669]: Connect time 2.2 minutes.
Fri Jul 21 17:31:57 2023 daemon.info pppd[6669]: Sent 30455 bytes, received 19607 bytes.
Fri Jul 21 17:31:57 2023 daemon.notice netifd: Network device 'ppp-wan2' link is down
Fri Jul 21 17:31:57 2023 daemon.debug pppd[6669]: Script /lib/netifd/ppp-down started (pid 7756)
Fri Jul 21 17:31:57 2023 daemon.debug pppd[6669]: sent [LCP TermReq id=0x2 "User request"]
Fri Jul 21 17:31:57 2023 daemon.debug pppd[6669]: rcvd [LCP TermAck id=0x2]
Fri Jul 21 17:31:57 2023 daemon.notice pppd[6669]: Connection terminated.
Fri Jul 21 17:31:57 2023 daemon.debug pppd[6669]: Script /lib/netifd/ppp-down finished (pid 7756), status = 0x1
Fri Jul 21 17:31:57 2023 daemon.info pppd[6669]: Exit.
Fri Jul 21 17:31:57 2023 daemon.notice netifd: Interface 'wan2' is now down
Fri Jul 21 17:31:57 2023 daemon.notice netifd: Interface 'wan2' is setting up now
Fri Jul 21 17:31:57 2023 daemon.notice pppd[7777]: pppd 2.4.9 started by root, uid 0

Then the process repeats. My modem doesn't respond to IPCP config requests UNLESS I leave on IPv6.
Here's my network file:


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'auto'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.1'

config device
        option name 'br-vlan'
        option type 'bridge'
        list ports 'eth0.3'

config interface 'vlan'
        option device 'br-vlan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'

config device
        option name 'eth0.2'
        option macaddr '0c:cf:89:6f:9b:f8'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0.2'

config interface 'wan2'
        option ifname 'ppp0'
        option proto 'ppp'
        option device '/dev/ttyUSB2'
        option speed '921600'
        option ipv6 'auto'
        option file '/etc/ppp/peers/att-QBG95'
        option connect '/usr/sbin/chat -v -f /etc/ppp/peers/att-QBG95-chat'
        option pppd_options 'debug persist'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'wwan'
        option proto 'dhcp'

Also, my modem is the Quectel BG95. What am I doing wrong?

You need to use proto 3g as shown here https://openwrt.org/docs/guide-user/network/wan/wwan/3gdongle

You may need to use context 3 with Verizon, just a guess.

So I switched to using the 3g protocol, and things got slightly better but are still broken. I was able to resolve and ping google for a brief moment after 3g-wan2 came up (which never appeared in ifconfig), but then that ability stopped.
Here's my logread:

Fri Jul 21 19:55:08 2023 local2.info chat[25933]: AT+QCSQ;+CEREG?;+COPS?;+CGDCONT?^M^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: +QCSQ: "GSM",-92^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: ^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: +CEREG: 0,4^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: ^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: +COPS: 0,0,"T-Mobile",0^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: ^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: +CGDCONT: 1,"IPV4V6","super","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: +CGDCONT: 2,"IPV4V6","ota.super","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: ^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: OK
Fri Jul 21 19:55:08 2023 local2.info chat[25933]:  -- got it
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: send (ATD*99#^M)
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: expect (CONNECT)
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: ^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: ATD*99#^M^M
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: CONNECT
Fri Jul 21 19:55:08 2023 local2.info chat[25933]:  -- got it
Fri Jul 21 19:55:08 2023 local2.info chat[25933]: send (150000000^M)
Fri Jul 21 19:55:08 2023 daemon.debug pppd[25899]: Script DIALNUMBER=*99***1# /usr/sbin/chat -t5 -v -E -f /etc/chatscripts/3g.chat finished (pid 25933), status = 0x0
Fri Jul 21 19:55:08 2023 daemon.info pppd[25899]: Serial connection established.
Fri Jul 21 19:55:08 2023 daemon.debug pppd[25899]: using channel 268
Fri Jul 21 19:55:08 2023 kern.info kernel: [ 7020.496939] 3g-wan2: renamed from ppp0
Fri Jul 21 19:55:08 2023 daemon.info pppd[25899]: Renamed interface ppp0 to 3g-wan2
Fri Jul 21 19:55:08 2023 daemon.info pppd[25899]: Using interface 3g-wan2
Fri Jul 21 19:55:08 2023 daemon.notice pppd[25899]: Connect: 3g-wan2 <--> /dev/ttyUSB2
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe0098fa1>]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: rcvd [LCP ConfReq id=0x7 <asyncmap 0x0> <auth chap MD5> <magic 0xb9189031> <pcomp> <accomp>]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: No auth is possible
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: sent [LCP ConfRej id=0x7 <auth chap MD5> <pcomp> <accomp>]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xe0098fa1>]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: rcvd [LCP ConfReq id=0x8 <asyncmap 0x0> <magic 0xb9189031>]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: sent [LCP ConfAck id=0x8 <asyncmap 0x0> <magic 0xb9189031>]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: sent [LCP EchoReq id=0x0 magic=0xe0098fa1]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: sent [IPV6CP ConfReq id=0x1 <addr fe80::b439:6c46:fc0d:20be>]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: rcvd [LCP DiscReq id=0x9 magic=0xb9189031]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: rcvd [LCP EchoRep id=0x0 magic=0xb9189031 e0 09 8f a1]
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: rcvd [LCP TermReq id=0xa]
Fri Jul 21 19:55:09 2023 daemon.info pppd[25899]: LCP terminated by peer
Fri Jul 21 19:55:09 2023 daemon.debug pppd[25899]: sent [LCP TermAck id=0xa]
Fri Jul 21 19:55:09 2023 daemon.notice pppd[25899]: Modem hangup
Fri Jul 21 19:55:09 2023 daemon.notice pppd[25899]: Connection terminated.
Fri Jul 21 19:55:10 2023 daemon.info pppd[25899]: Exit.
Fri Jul 21 19:55:10 2023 daemon.notice netifd: Interface 'wan2' is now down
Fri Jul 21 19:55:10 2023 daemon.notice netifd: Interface 'wan2' is setting up now

LCP terminated by peer, meaning my modem?

Please show your current interface configuration.
Are you sure about the APN and IPv4/IPv6 settings? Can you test the same SIM in the phone and see what addresses are assigned by the network?
And why it says T-Mobile now instead of Verizon?

That would be because my sim card does IMSI switching. I am sure about the APN, and my IP info. Interestingly, when I disable my firewall (doing service firewall stop then service network restart), it suddenly works. At least on this device. Devices connected to it's hosted wifi can't get internet, although they can ping the parent machine (the one with the cell modem connected)
Here's my network file:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'auto'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.1'

config device
        option name 'eth0.2'
        option macaddr '0c:cf:89:6f:9b:f8'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0.2'

config interface 'wan2'
        option ifname 'ppp0'
        option proto 'ppp'
        option device '/dev/ttyUSB2'
        option speed '921600'
        option file '/etc/ppp/peers/att-QBG95'
        option connect '/usr/sbin/chat -v -f /etc/ppp/peers/att-QBG95-chat'
        option pppd_options 'debug persist'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'wwan'
        option proto 'dhcp'

and my firewall file:

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'
        list network 'wan2'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_port '547'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled 'false'

config include
        option path '/etc/firewall.user'

Why it shows option proto 'ppp' instead of 3g ?

I changed it back to 'ppp' to eliminate variables, since it had no effect. The same chatscript got executed, and the same problem persists.

then you're on your own

1 Like