Potential issue with MT7628AN switchip

Hello. I am not sure if this is the right place to report, but if not will replicate this information in the correct place.

I have a TP-Link Archer C20 v4 which has a MT7628AN SoC running openwrt-19.07.2 and found a pretty strange issue I am being able to observe. This was also tested with 18.06.8 with the same results.

If I run a iperf test to another cable connected device it runs fine at full speed, therefore 100 Mbps.
However if I run any Internet Speedtest (speedtest.net, fast.com, etc) or any regular download I get a maximum speed of around 25 to 40Mbps.
I was getting these results connected on the 5Ghz radio and trying to rule out it I have connected directly via the cable and got the very same results so it doesn't seem to be anything related to the radio, but maybe to the internal switchip.(rt305x-esw).
In order to rule out the issue being the Internet connection I have directly connected the Laptop with cable to the main router and run the same same tests and the results were as expected maxing out the internet connection speed.
What makes it even more strange is that this device is not routing any traffic, but only acting as an Access Point in this scenario, so the only traffic that pass through it is layer 2 both in the radio and switchip.

Does anyone have any idea on what else can I look into to try identify better the possible issue ?

I’m not quite following the problem, maybe reframe it as a bug ticket? I.e.

  • Steps to recreate
    1. ABC
    2. Def
    3. Ghi
  • Result
  • And the result you were expecting

What part did you not understand exactly ? Tell me and I will re-phrase.

Is the device configured as a dumb access point or as a router. Does the traffic pass exclusively through the switch, or is the CPU involved?

Hi @eduperez
That's correct, it is configured as a dumb access point and the traffic pass exclusively through the switch, therefore CPU isn't involved.