Port to TP-Link RE200

You should follow fluxus's post right above your first post to get the web interface working.
Have the repeater connect to your router instead of your computer, and the computer also connected to the router.
ssh to the repeater from your computer and follow the commands fluxus posted.
Make sure router isn't also using, as it will conflict with the repeater.

I think snapshot might be broken again, at least for the RE210;
I used the factory snapshot here: https://openwrt.org/toh/hwdata/tp-link/tp-link_re210_v1
And the last firmware here: https://www.tp-link.com/us/support/download/re210/#Firmware
Followed the instruction to prepare the image here: https://openwrt.org/toh/tp-link/re200
Flashed through the TPlink GUI.

Now when it is plugged in, all lights flash for a second, and then power LED stays on. No DHCP server running on ethernet, and no response to pinging even if I use a static IP.
The device was left over from a dismantled setup, so I'm not too concerned about it being bricked, but just thought you should know.

1 Like

What's the status of RE200 v3 ? I see 2 comments above that looked helpful, but no one updated the wiki's device page with instructions for v3 . Is development still at the "have a serial cable handy" point, or is there a (relatively) safer build/install/failsafe method? And even if there's no "safe" install, can someone post what they've got working at this point?

On a side note, I downloaded the source code from TP-Link's site in the hopes that I could reverse engineer how the Tether App communicates using ssh (you can password authenticate with user: "admin" and the password you've set in the web GUI, but there's no shell/pty access and all the commands I've tried return an error). No solution yet. What's really annoying is that the code appears to be an earlier version of OpenWrt and yet I can't configure it! Has anyone figured this out?

Thanks for the link!

Btw, the GPL source for v3 is at https://static.tp-link.com/resources/gpl/re220v1_gplcode.tar.bz2 according to TP-Link (see https://www.tp-link.com/us/support/download/re200/v3/#GPL-Code)

They also list
as the code for the RE220v1 (see https://www.tp-link.com/us/support/download/re220/v1/#GPL-Code)
So I'm not surprised that the code for RE200v3 is almost identical to that for RE220v2

The only difference I see is this added line for RE200v3 in addition to the equivalent lines as for the RE220v2 (https://github.com/openwrt/openwrt/blob/master/tools/firmware-utils/src/tplink-safeloader.c)

"{ product_name:RE200,product_ver:3.0.0,special_id:45470000}\n"


which blocktrron confirmed 2 days ago in the pull request you linked

Would there be any added stability if I'd rebuild 19.07 with just the added lines from the recent RE200v3 commits, or is there an equal risk/instability in doing so as opposed to using a snapshot?

First of all thanks andyboeh for support RE200. I'm very new in openwrt. I built and flashed openwrt by tftp file "./bin/targets/ramips/mt76x8/openwrt-ramips-mt76x8-tplink_re200-v2-initramfs-kernel.bin". But I can't persist modify files and after restart my configuration is reset to default. How can I save to flash my configuration?

You flashed the wrong image. initramfs images are meant for development purposes and usually run entirely from RAM. They should not be flashed to a system.
Please read the Wiki for installation instructions, the easiest method is to install from the stock web interface: https://openwrt.org/toh/tp-link/re200

If you've really flashed the initramfs image, then you should be able to do a sysupgrade with a sysupgrade image.

This is a very interesting topic. I cannot wait to test this on my RE200 v3. But before doing so, what are the limitations of this implementation? What features will be lost from the original firmware compare to here? Also, is 802.11r supported on the OpenWRT RE200 v3?

If I want to go back the stock, I will need to install OpenWrt development environment, which only runs on Linux. Right?

Thanks. sysupgrade works for me

Neither do I own a v3 nor have i worked on a v3 so I cannot comment here. I only did the ports to v1 and v2.

If you want to go back to stock you will need an original firmware file and convert it to sysupgrade format. You will need only one small utility from the development environment.

Thanks for your reply andy. Are the Range Extender capabilities lost in RE200 v2? Is 5GHz working?

And regarding tplink-safeloader too, I will still need linux to run the development environment. Right?

5GHz is working. I've got three devices that I use regularly all with 2.4G and 5G active. I only use them in AP mode (something the stock firmware does not offer and the reason why I ported OpenWrt).

Relaying is a general OpenWrt question: https://openwrt.org/docs/guide-user/network/wifi/relay_configuration. Hardware-wise it's fully supported, so the rest are OpenWrt features (check the Wiki, please).

I think that it is part of the ImageBuilder, so you don't have to set up a dev environment. You can easily run this on a Linux system hosted in a virtual machine.

A word of caution (once again): Make sure that you know what you're doing, these devices do not have recovery features included in the boot loader and are hard to disassemble.

Thanks a lot Andy.
I am following up the Wiki here https://openwrt.org/toh/tp-link/re200. All seems good, expect the part reverting back to stock firmware for v3, which I assume it is the same as v2. The only thing different for me is part creating .bin file to use when reverting back to stock using sysupgrade -F. I have flashed and returned back to stock many times on WRT1900ACS successfully, whithout the need to unbrick it. I guess this shall not be any different.

It is now available in RE200 v3 as a stock feature.


Did you or someone get to solve this?

Did someone try/recommend flashing RE200 v4 with v3 image since they're both MT7628AN?

Thank you

Are you referring to this?

There is nothing really wrong with it: I never tried to bootm (the original poster did nit provide his exact commands), probably, the load address is wrong. And snapshot images do not have luci installed, that is by design. You can install it afterwards.

i have the exact same experience. Now my device is bricked and i have to somehow open the case and try to flash back the original firmware with serial connection if i can. Is there another solution?

There is a mistake in the Wiki, it says that the serial port uses TTL voltage which implies 0-5V range.

I measured on my RE200v1 and the voltages were 0-3.3V, which are usually CMOS (but CMOS can operate in a wide range of voltages).

Please fix the wiki that on the RE200v1 the voltages are 3.3V and not TTL.


PS: I tried flashing the latest snapshot from the wiki and it seems to brick.

It's a Wiki, so why don't you fix it yourself?