Port to TP-Link RE200

I tried the Chinese application and it didn't work for me, I'm sure I'm using it wrong, but I think it's getting a lot complicated for me, I'd better wait for them to release a stable image one day, thank s :wave::grinning:

https://firmware-selector.openwrt.org/?version=21.02.0-rc2&target=ramips%2Fmt7620&id=tplink_re200-v1

Hello, thank you very much, I tested the 21.02-SNAPSHOT, 21.02.0-rc1, 21.02.0-rc2 and the SNAPSHOT all the factory image, the first three give the error 1 and the last one the 2
1 : https://ibb.co/Yjb5k09
2 : https://ibb.co/p0zjkFD

Take a photo of the UI window in the google translate app, it'll show you the UI text in english.

The question @calebfn asked was answered in this thread several times - read through it, for example Port to TP-Link RE200 - #35 by LaercioCordeiro.

That said: mktplinkfw is part of the OpenWrt ImageBuilder and part of the OpenWrt SDK. You then need a hex editor to fix the checksum in your image.

The reason for why no GUI tool is available (well, it is, but in source code only) is that several people have completely bricked their devices and, due to the fact that there is no recovery mode present, had to either crack open their devices or had to throw them away.

1 Like

I'd better leave it as it is right now, at least it works, it might end up damaging it, Thank you very much, I don't bother you anymore :+1:

I've flashed latest all release canditates to my devices (re200 v3, re200 v4), both of them are connected via ethernet cable.

In my experience 5ghz radio is very unstable, it disconnects clients or causes big packet loss like every 5 minutes. 2.4Ghz radio on the other hand is mostly stable, but also have noticable "hiccups". Also, the 5Ghz band have very low transmit power.

Any solutions for 5ghz?

I would like to know the answer @GrzybDev. I just tried to get one of these supposedly supported RE200 devices to work with the latest OpenWrt release 21.02.0 and failed horribly . The 5Ghz seemed very unstable. I ended up bricking my device by trying to flash back to stock firmware using the OpenWrt web interface in desperation following hours of messing around, but I don't care because they are so cheap. If these are known to work properly in mesh mode I will buy more if I can know for sure they can be made to work well on OpenWrt.

I'd also be interested in alternatives for a repeater. I like these because they are so small. I use an RT3200 as the main router.

I would like to use my RE200 as a router and not as a repeater. My idea is to have a portable device that can be connected to a RJ-45 port and "master" a 2.4GHz wlan with adblock active, so that when I travel I don't have to setup my other portable devices and get rid of ads.

Is this possible ? If yes, may I have a sample config ?

I tried OpenWRT on my RE200 v2 earlier this year and the 5Ghz radio was not usable at all (see my reports up in this thread for more details). Luckily I was able to revert back to stock firmware without bricking my device.

Per latest comments I believe OpenWRT issues with this device unfortunately have not been resolved so far.

It’s really strange RE200 has been added as supported to the OpenWRT stable release. It’s far from being stable. This way I’m wondering if RE200 should be actually be removed from the OpenWRT stable releases and kept only in the snapshot releases until it’s actually stable.

To me it seems that OpenWRT is not loading the correct radio configuration or something in this line (I”m speculating only). However I’m not sure if the developer who initially added support to this device is still maintaining it.

1 Like

I'm not following this forum closely but several users reported problems with devices using MT76xx wlan chips. RE200 is one of them. Probably you have to wait until the MT76 driver is fixed before enabling 5GHz wlan.

Thanks to a user, I received an accidentally-bought RE200v5 for inspection. Unfortunately, TP-Link seems to have switched from Linux to VxWorks: The v5 only has 4MB of flash and the firmware file contains VxWorks signatures (according to binwalk). I forgot to check the RAM module, but the 4MB of flash and VxWorks prevents easy installation without opening the device.

To sum up:

The RE200 v5 cannot be (easily) supported by OpenWrt!

So where are we at with RE200 v4? Is it just unusable in OpenWrt? This seems such a shame because it is surely an excellent platform for OpenWrt. The device is very small and attractive and has excellent capabilities on stock firmware. As a repeater it works very well on stock - so why not on OpenWrt too with the usual benefits? I sincerely hope that OpenWrt can be made to work well on the RE200 v4 (and other versions).

Check this thread: https://github.com/openwrt/mt76/issues/227

@dsouza I agree - I think this device should be removed from the OpenWrt stable releases absent a fix that makes the 5Ghz actually work. Lots of users will flash OpenWrt and struggle to revert back to stock. In desperation they may like me even try flashing stock with LuCi without the changes you need the SDK for. BTW in case I need to go back again if I buy a new device did you get back to stock using the SDK tool to modify the stock image?

@Lynx, yes, I did follow the instructions about using the SDK tool to prepare the stock image to revert back to stock firmware.

I have installed the latest OpenWRT build on my RE200 v4 and everything works fine so far. But I am unable to change the LAN port to Gigabit speed, which makes the device rather useless.
Is there any way to force the port to 1000MBit?
I have tried command
swconfig dev switch0 port 4 set link "speed 1000 duplex full"
but I get "operation not supported".
Any suggestions?

The RE200 does not support Gigabit, it's 100M only.

1 Like

That's a pity. Thanks for pointing that out.

This topic was intended for adding support for this specific device.
Since official 21.02.0 images are available now, I will set a timer for this topic to close.

Why?

Because specific problems for this device with official releases are better handled in separate topics, in order to make finding relevant information easier. Who is going to read the previous 200-something postings, if he has a specific problem with 21.02.0 and wifi?

Therefore: Please open new topics for any open issues with this device.

Thanks! :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.