Port Shutdown Behavior Is Different

There are two x86 devices, both are running same version of Openwrt (22.03.05)

On Device A, when I execute ifconfig eth1 down , the port can fully shuts down, and the port light turns off.

However, on Device B, using the same ifconfig eth1 down command, the port doesn't seem to shut down completely. The port light briefly turns off but then lights up again. When checking the port status, it shows as "DOWN", but it still receives data. Here's the status I see:

eth1: <BROADCAST,MULTICAST800> mtu 1500 qdisc mq master bond-bond1 state DOWN qlen 1000
    link/ether 34:1b:2c:02:d3:15 brd ff:ff:ff:ff:ff:ff

How can I fully shut down the port on Device B?

I know this is hardware-related. If all else fails, can I move the hard disk from Device B into Device A? These two devices have the same number of interfaces, but the CPU and motherboard are different.

maybe power management setting in the bios for wake on LAN

I tried, but same result. Since Device A's hardware can fully shutdown the port, can I move the harddisk from Device B to Device A??

You should be able to see any differences in the WoL/power management with ethtool eth0 or whatever interface it's using. My N5105 i226 NICs show this, for example, where the Wake-on: g means WoL is on (i.e., the NIC won't go down all the way).

$ ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
                                2500baseT/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
                                2500baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 2500Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: off (auto)
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes
1 Like