Port mirroring is not working

Hi all,

I have tried port mirroring in my router which has OpenWRT 21.02.1, but i could not see any mirrored packets from eth0.1 to eth0.4

Configuration:

config 'port-mirroring'
    option source_ports 'eth0.1'    # interfaces (maximum of 4) to copy packets from
    option promiscuous  '1'             # put source interface(s) in promiscuous mode
    option target       'eth0.4'      # interface or IP address to send packets to
    option protocol     'TEE'           # 'TEE' iptables (default) or 'TZSP' TaZmen Sniffer Protocol
    option filter       ''              # optional tcpdump/libpcap packet filter expressions

root@openwrt:/# ps | grep -i port
 7316 root      6572 S    port-mirroring --daemon --syslog
 7334 root      3324 S    grep -i port

network configuration:
config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option lastchange '2005'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fdea:e111:ce6b::/48'

config route6
        option route6_instance '1'
        option static '0'
        option target 'fe80::/64'
        option metric '256'
        option renabled '1'

config route6
        option route6_instance '2'
        option static '0'
        option target 'fe80::/64'
        option metric '256'
        option interface 'wan'

config interface 'lan'
        option force_link '1'
        option proto 'static'
        option ipaddr '192.168.29.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'br-lan'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
        list ports 'eth0.2'
        list ports 'eth0.3'
        list ports 'eth0.4'
        option igmp_snooping '1'

Could you post output of
ubus call system board
I do not see VLAN definitions or switch config in your /etc/config/network

This is EOL and unsupported. It has many known security vulnerabilities and should not be in use. (as an aside, the 21.02 series went up to 21.02.7).
This looks entirely invalid:

What is the device?

ubus call system board
ubus call system board
{
        "kernel": "5.4.55",
        "hostname": "Openwrt",
        "system": "ARMv7 Processor rev 4 (v7l)",
        "model": "ECONET (Device Tree)",
        "board_name": "econet,en75XX",
}

This is not supported by the official OpenWrt project. The firmware you are running is not from here -- it's probably from the product vendor.

You'll need to ask the vendor or maintainer of that firmware for help.

double check the port numbering
lan1 in the firmware is not always the one belled lan1 on the case
test them via plugin them in and watching it detect the cable