Port Forwarding

I've had users report Port Fowarding is not working since Snapshot r11962. I just compiled snapshot r12121 yesterday, and port forwarding doesn't appear to be working.

I've really relaxed my firewall settings to test and ensure Port Forwarding is working but isn't. I can see the packets hitting the outside interface, but none are forwarded to my workstation. I run tcpdump on my workstation so I'm sitting waiting for them, but never arrive. Also, GRC Shields Up, shows the port as "Closed" though I have an app listening to the port, so I know it isn't working correctly.

Just to Relax everything I've set, Input, Output and Forward to Accept, for the top 3 options, and did the same for the WAN Zone. I created a port foward rule, and allowed any Source IP with a specific dst port, and forwarded to LAN, to my workstations IP address on the LAN. I've tried saving, and rebooting the router, but the port stays closed and never reach my workstation.

Can someone else verify if port forwarding is working on a build as new or newer than r11962.



Works fine here on r12115.


Working on r12138.